Make WordPress Core

Opened 15 months ago

Closed 15 months ago

Last modified 14 months ago

#57929 closed defect (bug) (fixed)

Regression: Only page links show up in top level navigation block links

Reported by: thomask's profile thomask Owned by: hellofromtonya's profile hellofromTonya
Milestone: 6.2 Priority: normal
Severity: normal Version: 6.2
Component: Menus Keywords: gutenberg-merge dev-reviewed
Focuses: Cc:

Description

It is not possible to put category, post or CPT link to the top level of gutenberg navigation block - only manually write the address - they do not show up in the add link popup upon searching. However they show up when you add submenu link.

compare the popup on the left and right part of the image.

Attachments (1)

Snímek obrazovky 2023-03-15 143626.png (1.2 MB) - added by thomask 15 months ago.
compare the add link popup on the left and right side - one with submenu link shows post, category and CPT in the search, the second shows nothing (it would show only pages)

Download all attachments as: .zip

Change History (13)

@thomask
15 months ago

compare the add link popup on the left and right side - one with submenu link shows post, category and CPT in the search, the second shows nothing (it would show only pages)

#1 follow-up: @costdev
15 months ago

  • Focuses javascript removed
  • Keywords dev-feedback added
  • Milestone changed from Awaiting Review to 6.2

Hi @thomask, thanks for opening this ticket.

It appears this was a design decision, see https://github.com/WordPress/gutenberg/pull/48740.

  • Merged in [55475].
  • Milestoning for 6.2 to raise awareness and track any possible changes.
  • Pinging @mamaduka, @ntsekouras, @hellofromTonya (as committer of [55475]) to see if this needs an issue upstream, or if there will be no change.

#2 @costdev
15 months ago

  • Keywords gutenberg-merge added; needs-patch dev-feedback removed

Issue reported on the Gutenberg repository: https://github.com/WordPress/gutenberg/issues/49107

Keeping this ticket open to track changes coming from the Gutenberg repository.

#3 in reply to: ↑ 1 @thomask
15 months ago

Replying to costdev:

It appears this was a design decision, see https://github.com/WordPress/gutenberg/pull/48740.

Thank you for pointing this out, this is probably the reason, but they somehow throw the baby out with the bath water - i can somehow understand, why they exclude block posts from the nav (but event that should be possible to turn off by some well documented filter), but they should not dot it by including only pages, because that way they block everything - including categories and CPT that has turned on the visibility in nav in their settings.

And what is completely unclear for me, is why it has different behaviour for top links and different for submenus.

IMO best hotfix should be excluding posts and leave everything else plus having some easy filter and what to exclude/include (it might make nice to be able to filter it e.g diferently for editors in different post types). And on long run it would be great to have option to select what should be returned directly in the popup with some easy configure box with all the post types and taxonomies.

#4 @hellofromTonya
15 months ago

  • Keywords needs-testing added
  • Owner set to hellofromTonya
  • Status changed from new to assigned
  • Summary changed from only page links show up in top level navigation block links to Regression: Only page links show up in top level navigation block links

Update:

The Navigation Block change that caused this regression was reverted in Gutenberg today.

It will be included in the 6.2 RC3 @wordpress package updates (see #57471). Once committed, @thomask and @costdev would appreciate you retesting to confirm the reported issue is indeed resolved.

#5 @costdev
15 months ago

@hellofromTonya For now, I can verify that with Gutenberg trunk, the issue is gone. I'll also re-test when the packages are merged for 6.2 RC3 as requested.

#6 @hellofromTonya
15 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 55568:

Editor: Update @wordpress packages for 6.2 RC3.

Updates the @wordpress packages to include the fixes for these regressions introduced in the 6.2 cycle:

  • [Regression] Navigation Block: Category/Custom taxonomy links are not searchable in the Link inserter Gutenberg PR 49126. See #57929
  • [Regression] Post Editor: List View has no close button on mobile viewports Gutenberg PR 49200

References:

Follow-up to [55548].

Props andraganescu, costdev, get_dave, hellofromTonya, mamaduka, ntsekouras, scruffian, talldanwp, thomask.
See #57471.
Fixes #57929.

#7 @hellofromTonya
15 months ago

  • Keywords reporter-feedback added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Re-opening for committer double signoff to backport [55568] to the 6.2 branch for RC3.

#8 @SergeyBiryukov
15 months ago

  • Keywords dev-reviewed added; reporter-feedback removed

[55568] looks good to backport.

#9 @hellofromTonya
15 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 55570:

Editor: Update @wordpress packages for 6.2 RC3.

Updates the @wordpress packages to include the fixes for these regressions introduced in the 6.2 cycle:

  • [Regression] Navigation Block: Category/Custom taxonomy links are not searchable in the Link inserter Gutenberg PR 49126. See #57929
  • [Regression] Post Editor: List View has no close button on mobile viewports Gutenberg PR 49200

References:

Follow-up to [55548].

Props andraganescu, costdev, get_dave, hellofromTonya, mamaduka, ntsekouras, scruffian, talldanwp, thomask.
Reviewed by SergeyBiryukov, audrasjb.
Merges [55568] to the 6.2 branch.
See #57471.
Fixes #57929.

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


15 months ago

#11 @hellofromTonya
15 months ago

  • Keywords needs-testing removed

During today's RC3 release party, multiple contributors tested to confirm that this regression is fixed. The testing thread starts here in Making WordPress slack.

This ticket was mentioned in Slack in #core by bph. View the logs.


14 months ago

Note: See TracTickets for help on using tickets.