WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 12 years ago

#5793 closed defect (bug) (fixed)

Bad Math (and No Publication) of Midnight-Hour Posts

Reported by: iacas Owned by:
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.3.3
Component: Date/Time Keywords: midnight
Focuses: Cc:

Description

I've begun a blog with 366 pre-built entries for the next year at http://pic.nslog.com/ .

I first tried setting the date and time to 00:00:00 (and GMT to 05:00:00). That didn't work and my entries weren't auto-published at midnight. Next I tried 00:01:00 (and 05:01:00). That doesn't work either.

Curiously, when you log in at, say, 9am, the post that should have been published at midnight will say it will be published in 9 hours. The math is backwards. The post that should go up at midnight that day properly says "in 15 hours."

I wrote more about this here:
http://nslog.com/2008/02/07/wordpress_time_bug_for_midnight_posts

I believe that the problem is the first 00, and I'll try 01:00:00 (and 06:00:00) soon, but there's still a bug.

P.S. WordPress 2.3.2 and 2.3.3 are affected by this bug. There's no choice for 2.3.3 in the popup.

Change History (4)

#1 @lloydbudd
14 years ago

  • Milestone changed from 2.3.4 to 2.5
  • Version changed from 2.3.2 to 2.3.3

#2 @iacas
14 years ago

I changed all of the times to 01:00:00 and 06:00:00 and the bug still appears. The Dashboard said "in 8 hours" this morning at 9am, and I again had to click "Save and Continue Editing" to get the scheduled entry to appear.

I'm going to check in the database tomorrow to see what, if anything, is changed by clicking just "Save and Continue" because I'm not editing anything.

#3 @Denis-de-Bernardy
12 years ago

  • Component changed from General to Date/Time
  • Owner anonymous deleted

still current?

#4 @ryan
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Resolving as fixed due to the number of scheduling fixes since then.

Note: See TracTickets for help on using tickets.