Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#57930 closed defect (bug) (wontfix)

Remove Heading in uppercase in the h5 and h6 for Twenty Twenty three theme.

Reported by: nidhidhandhukiya's profile nidhidhandhukiya Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords:
Focuses: css Cc:

Description

Choose Twenty Twenty three theme.
Choose Heading block.
Add some text
Now change the Heading level from h1 to h4.
It is working fine.
If you choose heading level h5 or h6 it is showing in uppercase.
As we already provide option in editor for choosing the text-transformation then we don't need to provide the text in uppercase for H5 and H6.

I have attached the video for better understanding.
Video URL :- https://share.cleanshot.com/w1Jpy8CGVlly6ZYjfv7k

Attachments (1)

2023-heading-letter-case.png (13.2 KB) - added by sabernhardt 16 months ago.
Setting H5 letter casing to the "None" option in global styles

Download all attachments as: .zip

Change History (5)

#1 @nidhidhandhukiya
16 months ago

As a solution of this issue we have to remove the css which is for default h5 and h6.

    text-transform: uppercase;

If we remove this the issue is resolved.

#2 @audrasjb
16 months ago

  • Keywords 2nd-opinion added

Hello and thanks for the ticket,

I understand that this CSS declaration is not anymore relevant with the block editor, but in another hand I feel a bit hesitant about changing the design of old themes, as it can also be understood as a backwards compatibility issue: "before updating my site, my headings were using uppercase, and now that I updated, they are all lowercase, please fix this regression".

@sabernhardt
16 months ago

Setting H5 letter casing to the "None" option in global styles

#3 @sabernhardt
16 months ago

  • Focuses css added
  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I don't like uppercase as a default, but it needs to stay that way now. In #49710, Twenty Twenty removed the similar uppercase styling for Button blocks, yet that was reverted to avoid making changes that people would not expect on their existing sites.

As a block theme, Twenty Twenty-Three has the opportunity to change the default letter casing to the "None" option in global styles, and each heading block can override those styles individually.

#4 @sabernhardt
16 months ago

#58097 was marked as a duplicate.

Note: See TracTickets for help on using tickets.