Make WordPress Core

Opened 15 months ago

Last modified 15 months ago

#57991 new defect (bug)

Child theme in multisite shows error

Reported by: madhudollu's profile madhudollu Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 6.1.1
Component: Themes Keywords: reporter-feedback
Focuses: multisite Cc:

Description

Issue:

Child theme in multi shows following error even though parent theme is installed.

Error: The parent theme is missing. Please install the "twentytwentythree" parent theme.

Steps:

  • Create a multisite environment with sub directories.
  • create a child theme of TT3
  • Activate the child theme.
  • Install WooCommerce plugin
  • And network enable the plugin.

More information on the issue:
https://wordpress.org/support/topic/child-theme-in-multisite-shows-error/?view=all

Attachments (1)

parent-theme-error.png (324.5 KB) - added by madhudollu 15 months ago.
Error message

Download all attachments as: .zip

Change History (3)

@madhudollu
15 months ago

Error message

#1 @peterwilsoncc
15 months ago

  • Keywords reporter-feedback added

Hi @madhudollu and thanks for the ticket.

Are you able to reproduce this error without the install WooCommerce step?

If the error only happens with WC installed (and activated, I presume), it suggests the issue is in the plugin and best reported to their developers.

Thanks,
Peter

#2 @dd32
15 months ago

Additionally; @madhudollu have you enabled the twentytwentythree theme for the multisite site?

If the site doesn't have the theme as an allowed theme, it won't be able to find the parent theme, which would cause this I believe.

Note: See TracTickets for help on using tickets.