Make WordPress Core

Opened 14 months ago

Closed 14 months ago

Last modified 13 months ago

#58003 closed defect (bug) (duplicate)

Reset password link for user with email contained single quote

Reported by: ilianskia's profile ilianskia Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2
Component: Users Keywords:
Focuses: Cc:

Description

The users with emails that containts single quotes on the email are not able to use reset password function.
Users with email similar to – test.t’test@….
Can click on Reset password link but when the email with link came to the user mailbox and the user click on reset link when the page is opened it shows the error message- Error: Your password reset link appears to be invalid. Please request a new link below.
The issue is only for the users with emails similar to the above.
Not related to any theme or plugin as i tested with default wp theme and 2-3 default plugins.
Not related to link is expired in real as tested with 10 different emails without single quote on them but the reset link password works for all of them.
So far tried to do any fix but no success yet.
Probably is a core WP issue.
I do test on the site with WP version-WordPress 6.1.1

Change History (4)

#1 @kebbet
14 months ago

  • Component changed from Login and Registration to Users
  • Resolution set to duplicate
  • Severity changed from blocker to normal
  • Status changed from new to closed
  • Summary changed from Issue- Reset password link for user with email contained single quote to Reset password link for user with email contained single quote
  • Version changed from 6.1.1 to 2.2

Duplicate of #53699.

#2 @kebbet
14 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#3 @kebbet
14 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #52529.

#4 @desrosj
13 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.