Make WordPress Core

Opened 13 months ago

Closed 4 weeks ago

Last modified 4 weeks ago

#58074 closed defect (bug) (fixed)

Twenty Twelve: Table block font size not changing in editor or front-end

Reported by: sheulyshila's profile sheulyshila Owned by: karmatosed's profile karmatosed
Milestone: 6.6 Priority: normal
Severity: normal Version: 6.2
Component: Bundled Theme Keywords: has-patch commit
Focuses: css Cc:

Description (last modified by sabernhardt)

Steps to reproduce the issue:

  1. Activate Twenty Twelve Theme.
  2. Choose table block.
  3. Apply font size to table block (preset or custom).
  4. Now see the setting does not change the font size in the editor or on the front.

I have attached video for better understanding.
video url:
https://drive.google.com/file/d/1ILmauVB7mje5PsxmtLfIPxypwXzwIjZN/view?usp=sharing

Attachments (4)

58074.diff (948 bytes) - added by sheulyshila 13 months ago.
After applying this solution the issue is resolved.
58074.1.diff (1.1 KB) - added by sabernhardt 13 months ago.
when a user selects a different font size for the table block, any child element inherits that size
SCR-20240328-rvcq.png (124.7 KB) - added by karmatosed 4 weeks ago.
Before patch
SCR-20240328-rvoo.png (133.1 KB) - added by karmatosed 4 weeks ago.
After patch

Download all attachments as: .zip

Change History (13)

@sheulyshila
13 months ago

After applying this solution the issue is resolved.

#1 @tahmidulkarim
13 months ago

  • Keywords has-patch added

@sabernhardt
13 months ago

when a user selects a different font size for the table block, any child element inherits that size

#2 @sabernhardt
13 months ago

  • Description modified (diff)
  • Summary changed from Twenty Twelve Theme Table font size not changing in editor and front-end part to Twenty Twelve: Table block font size not changing in editor or front-end

This is tricky because the regular table styles need to stay the same for anyone who likes the standard font sizes for th and td cells. Patches related to block features also should not change tables created in the Classic Editor.

58074.1.diff uses the universal selector for any child element. If listing individual elements would be better, then the table, th and td elements all need to inherit the block style.

#3 @sabernhardt
13 months ago

Thanks for the report and the patch! Welcome!

#4 @iamfarhan09
11 months ago

I also faced this in the Twenty Twelve and Twenty Ten theme table block font size issue on the editor side. I think this issue needs to be fixed.

Screenshot: https://prnt.sc/KI9g7zCbs_4U

#5 @karmatosed
4 weeks ago

  • Keywords commit added

@iamfarhan09 if you have experienced this also in Twenty Ten please open a ticket to report that as this ticket is focusing on one specific theme. Then we can fix that one also, thank you.

I can confirm I am also experiencing this in Twenty Twelve and that the patch does fix it from @sabernhardt. Thank you everyone for your collaboration here. I do agree it is tricky, but in this case I think the latest patch is the best balance for this theme.

I will add the commit keyword to reflect that.

@karmatosed
4 weeks ago

Before patch

@karmatosed
4 weeks ago

After patch

#6 @karmatosed
4 weeks ago

  • Owner set to karmatosed
  • Resolution set to fixed
  • Status changed from new to closed

In 57897:

Twenty Twelve: Fixes table block font size not changing.

Currently the table block font size does not change in the editor or front-end. This ensures this is reflected in the table block.

Props sabernhardt, tahmidulkarim, sheulyshila.
Fixes #58074.

#7 @karmatosed
4 weeks ago

I have committed this as a best case for now. I think there are improvements to be done in the way we handle blocks and specifically the font and color changing, for now though we are a little catching things one by one and finding the best path through it. Thank you everyone for the collaboration in doing this.

#8 @sabernhardt
4 weeks ago

  • Milestone changed from Awaiting Review to 6.6

#9 @iamfarhan09
4 weeks ago

Hello @karmatosed ,

I've already submitted the ticket for the issue you mentioned. You can track its progress at the following link: https://core.trac.wordpress.org/ticket/58362

Thank You.

Note: See TracTickets for help on using tickets.