Make WordPress Core

#58084 closed enhancement (duplicate)

Update jQuery to 3.7.0

Reported by: jorbin's profile jorbin Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: External Libraries Keywords:
Focuses: javascript Cc:

Description

The jQuery team pinged in slack with the following message
---
Hey! The jQuery team is preparing for a release of jQuery 3.7.0. While formally not a breaking update, there are major changes in that version that incur some risk. Before we release, I'm trying to verify the changes are not breaking important projects.

What we'll release as 3.7.0 should be very similar to what you can currently find at https://releases.jquery.com/git/jquery-3.x-git.js.

Do you have some tests you could invoke on that pre-release version?

Summary of the most risky changes:

  • removal of Sizzle in favor of inlining the selector engine code within jQuery with a lot of removals of workarounds for legacy browsers - we have tests but there's always risk we removed too much
  • implementing the focus jQuery event in IE via focusin and blur via focusout - this is because focusin & focusout native handlers are executed synchronously in IE while focus & blur are async; in other browsers, all 4 are sync

I guess the second part doesn't affect you since you don't support IE anymore?

Change History (1)

#1 @jorbin
14 months ago

  • Milestone 6.3 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #58083.

Note: See TracTickets for help on using tickets.