WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#5816 closed defect (bug) (fixed)

Long titles break edit permalink box

Reported by: ryan Owned by: nbachiyski
Milestone: 2.5 Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: permalink
Focuses: Cc:

Description

Edit a post with a long title. Click the permalink Edit button. Ellipses are present in the middle of the slug. Press Save without changing the slug. The permalink is now -1.

Attachments (2)

slug-ajax-nonce.diff (1.6 KB) - added by nbachiyski 10 years ago.
use-real-slug.diff (2.8 KB) - added by nbachiyski 10 years ago.

Download all attachments as: .zip

Change History (7)

#1 @nbachiyski
10 years ago

Actually the problem wasn't in long titles, the same happened with short ones too :-) The ajax request didn't have a proper nonce, that's why the -1 appeared.

#2 @ryan
10 years ago

(In [6788]) Fix edit slug ajax nonce. props nbachiyski. see #5816

#3 @ryan
10 years ago

The ellipsis still end up in the final slug.

#4 @nbachiyski
10 years ago

In the beginning it was the intended behaviour, but now I realize it was rather stupid. Here is a patch, which shows the whole slug in the edit box.

#5 @ryan
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6794]) Use full slug, not abbreviated slug, when editing. Props nbachiyski. fixes #5816

Note: See TracTickets for help on using tickets.