WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5826 closed defect (bug) (duplicate)

uploader can't handle filename with non-english characters

Reported by: gamerhk Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3.3
Component: Administration Keywords: upload, filename, 404
Focuses: Cc:

Description

When i upload a file with chinese filename (圖像006.jpg), the file is saved as

%e5%9c%96%e5%83%8f066.jpg

in the file system.

However, when wordpress tries to load the pic, it shows the image as

http://mydomain/path/%e5%9c%96%e5%83%8f066.jpg

rather than

http://mydomain/path/%25e5%259c%2596%25e5%2583%258f066.jpg

which causes a 404

Change History (2)

comment:1 @filosofo8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #5587

comment:2 @Nazgul8 years ago

  • Milestone 2.3.4 deleted
Note: See TracTickets for help on using tickets.