Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#58262 closed defect (bug) (duplicate)

"Visit plugin site" should open in a new window

Reported by: jason2022's profile jason2022 Owned by:
Milestone: Priority: normal
Severity: minor Version: 6.2
Component: Plugins Keywords:
Focuses: ui, administration Cc:

Description (last modified by SergeyBiryukov)

This one seems like a no-brainer: when viewing the plugins listing page in wp-admin, several of the plugins have a "visit plugin site" link, which I expect would open the target page in a new window when clicked. Yet it navigates away from the wp-admin website and takes me the plugin's website.

There are several tickets to get this fixed, one was opened 11 years ago! Yikes!

#20839

The comments in that ticket are TLDR, for what seems like it should be an easy fix. It is a minor inconvenience, but eleven years without a fix? My morning alarm only allows me to snooze 3 times :)

Can you please correct this?

Change History (3)

#1 @TimothyBlynJacobs
12 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20839.

Hi @jason2022,

Welcome to trac! As you've mentioned there already is a ticket tracking this issue. I'm going to close this as a duplicate so we can keep the discussion all in one place.

Discussion can continue on a closed ticket, so do feel free to add a comment indicating your support.

#2 @jason2022
12 months ago

Thanks Tim

#3 @SergeyBiryukov
12 months ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.