WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#5844 closed defect (bug) (fixed)

remove extra <ul> in walker class

Reported by: hailin Owned by:
Milestone: 2.5 Priority: normal
Severity: normal Version: 2.5
Component: General Keywords:
Focuses: Cc:

Description (last modified by lloydbudd)

As reported by James R Whitehead of interconnectit.com on wp-hackers:

I'm wondering why the html generated by wp_list_pages and
wp_list_categories has changed in the current 2.4-bleeding. I know
things in this are not set in stone so I'm hoping it's not a permanent change as it makes coding CSS menus that work with 2.3 and 2.4 very difficult especially as child item are no longer in a single container. The new structure also makes less sense semantically as each child is now a separate UL.

Changed from:

<ul>

<li>

Text
<ul>

<li>text</li>
<li>text</li>
<li>text</li>

<ul>

</li>

</ul>

To:

<ul>

<li>

Text
<ul>

<li>text</li>

<ul>
<ul>

<li>text</li>

<ul>
<ul>

<li>text</li>

<ul>

</li>

</ul>

Attachments (1)

5844_walker_ul.diff (2.5 KB) - added by hailin 6 years ago.
new patch

Download all attachments as: .zip

Change History (7)

comment:1 lloydbudd6 years ago

  • Description modified (diff)
  • Milestone changed from 2.6 to 2.5
  • Version set to 2.5

comment:2 ryan6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6835]) Walker markup fixes from hailin. fixes #5844

comment:3 ryan6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Looks like this is causing some problems with the depth arg.

comment:4 ryan6 years ago

(In [6839]) Revert [6835] as it breaks the depth arg. see#5844

hailin6 years ago

new patch

comment:5 hailin6 years ago

the issue is that when $depth = 1, it creates empty <ul> </ul>.
The new patch addresses that: it checks earlier so it won't descend another level if not necessary. Verified with blogs with depth=1 theme (mwlibrary.wordpress.com).

comment:6 ryan6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [6858]) Walker markup fixes from hailin. fixes #5844

Note: See TracTickets for help on using tickets.