Make WordPress Core

Opened 12 months ago

Closed 2 months ago

#58441 closed defect (bug) (wontfix)

Twenty Nineteen: Image block align center is not centered on the page

Reported by: nidhidhandhukiya's profile nidhidhandhukiya Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.0.3
Component: Bundled Theme Keywords: close
Focuses: css Cc:

Description

Steps to reproduce the issue :-

  1. Activate Twenty Nineteen theme.
  2. Take Image block.
  3. Upload Image.
  4. Give it width any except 100% to check the difference.
  5. Give it Alignment Center.

You can able to see both side if you make it align-left or align-right is working fine but when you make it align-center it is not center aligned proeprly.

I have attached the video for better understanding.
Video URL :- https://share.cleanshot.com/hvVMLHg00BlrnBTPGXDX

Attachments (2)

58441.patch (1.0 KB) - added by nkeller15 12 months ago.
CSS patch
Twenty-Nineteen-center-image-blocks.png (1.3 MB) - added by sabernhardt 12 months ago.

Download all attachments as: .zip

Change History (5)

@nkeller15
12 months ago

CSS patch

#1 @sabernhardt
12 months ago

  • Focuses css added
  • Keywords close added
  • Summary changed from Twenty Nineteen Image align center is not working proper. to Twenty Nineteen: Image block align center is not centered on the page
  • Version changed from 6.2.2 to 5.0.3

Thanks for the ticket and patch.

[44371] added that zero margin for centered image blocks. If I read #45716 correctly, this was intentional. The image is not centered according to the page width, but it centers within the content area.

#2 @sabernhardt
9 months ago

#59202 was marked as a duplicate.

#3 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

It seems to be that this issue was intentional and therefore it's being recommended for close. I agree based on reviewing the ticket and connected one. In this case, let's close and we can always reconsider if others want that. Thank you everyone for collaborating on this.

Note: See TracTickets for help on using tickets.