Make WordPress Core

Opened 11 months ago

Closed 9 days ago

#58446 closed defect (bug) (wontfix)

Twenty Fourteen: no space between Buttons block and Columns block on front end

Reported by: algorithmsunlocks's profile algorithmsunlocks Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9
Component: Bundled Theme Keywords: close
Focuses: Cc:

Description

Follow the Steps to reproduce the issue.

  1. Activate the Twenty-Fourteen theme.
  2. Choose a Button and a column block.
  3. Add some text.
  4. Apply to customize styles
  5. Now check it on the user side.

It is looking proper in the editor but having issues on the user side.
I have attached a video for better understanding.
Video Link:
https://www.loom.com/share/48f0cb53627a4448a9133595fb0e54ff

Change History (6)

This ticket was mentioned in Slack in #core by algorithmsunlocks. View the logs.


11 months ago

#2 @algorithmsunlocks
10 months ago

  • Severity changed from normal to critical

#3 @sabernhardt
10 months ago

  • Focuses ui accessibility javascript css removed
  • Keywords needs-patch removed
  • Severity changed from critical to normal
  • Summary changed from Twenty Fourteen: Columns block did not have space between others component to Twenty Fourteen: no space between Buttons block and Columns block on front end
  • Version changed from trunk to 5.9

The Button block's small default bottom margin was removed in GB34546, which resulted in no margin on either the Buttons or Button blocks for Twenty Fourteen and other themes. I would have recommended a default margin above and below the Buttons block for any theme, but Twenty Eleven gives each individual link a top and bottom margin of 20px and Twenty Seventeen gives each a top margin of 2em.

With Gutenberg 16 (and probably the next WordPress version), the Buttons block has a setting to add a specific margin to the Buttons block. I think the current workaround of adding Spacer blocks could be easier than finding that setting in the sidebar for classic themes.

#4 @algorithmsunlocks
9 months ago

It seems to be a possible bug in the Twenty-Fourteen themes. Why should I use the spacer blocks instead of normal?

#5 @karmatosed
2 weeks ago

  • Keywords close added

I agree with your suggestion @sabernhardt and for me the recommendation would be to close this over add to theme anything. That said as I add the close keyword that doesn't stop discussion so if anyone feels this shouldn't be the case please add your voice to the discussion. Thank you.

#6 @karmatosed
9 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I am going to close this for now, thank you.

Note: See TracTickets for help on using tickets.