Make WordPress Core

Opened 13 months ago

Closed 13 months ago

Last modified 6 months ago

#58465 closed defect (bug) (invalid)

Cannot use Apostrophe in email

Reported by: jane-blonde's profile Jane Blonde Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.2.2
Component: General Keywords:
Focuses: Cc:

Description

Hi Guys,

We cannot add an email address with an apostrophe, for example DavidO'Byrne@…

Is this a bug or a policy decision?

Is there a work around?

David

Change History (6)

#1 @dingo_d
13 months ago

Hi Jane!

Can you share in which context this email fails to work? Is this when you try to register a user? Are plugins installed which are modifying some email validation functionality?

Is this related to your personal site or wordpress.org?

More information is needed in order to see what the problem is, and if this issue is valid for trac, or if it should be asked in support forums.

The is_email function will accept the apostrophe character.

#2 @dingo_d
13 months ago

  • Focuses coding-standards removed

#3 @Jane Blonde
13 months ago

  • Resolution set to invalid
  • Status changed from new to closed

This issue happens when adding or updating a user via the users admin interface, there is Woocommerce which allows apostrophes into customer detail, and Profile Builder and Obfuscate Email.

I've debugged all 3 and found that the problem only occurs when Profile Builder is active.

Thanks for this, hopefully this helps others going forward, I couldn't find anything on the web.

DDH

Version 0, edited 13 months ago by Jane Blonde (next)

#4 @dingo_d
13 months ago

Glad you were able to debug the problem :)

You can contact the authors of the Profile Builder plugin https://wordpress.org/support/plugin/profile-builder/ so that they can debug the issue.

Good luck!

#5 @dingo_d
13 months ago

  • Focuses ui removed

#6 @swissspidy
6 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.