Make WordPress Core

Opened 12 months ago

Last modified 12 months ago

#58518 new defect (bug)

"More info about performance optimization" links in Site Health go to 404 error on WordPress.org

Reported by: jeffgreendesign's profile jeffgreendesign Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Site Health Keywords:
Focuses: docs Cc:

Description

On the Site Health page, at least under the "Enqueued scripts" improvements, the links for "More info about performance optimization" go to a broken link on wordpress.org (https://wordpress.org/support/article/optimization/). According to archive.org, it looks like that link was live as late as May 16, 2023. Not sure if there is now a new page. The only optimization page is https://wordpress.org/documentation/article/search-engine-optimization/.

Change History (10)

#1 @SergeyBiryukov
12 months ago

#58521 was marked as a duplicate.

#2 @sabernhardt
12 months ago

The page was deleted two weeks ago according to the issue tracker:
https://github.com/WordPress/Documentation-Issue-Tracker/issues/795

Another issue suggests there might be an updated version in the future (possibly with a different URL):
https://github.com/WordPress/Documentation-Issue-Tracker/issues/824

#3 follow-up: @SergeyBiryukov
12 months ago

Hi there, welcome to WordPress Trac! Thanks for the report.

I was able to find some context in a comment on Slack by @stevenlinx:

The "Optimization" page now resides in Advanced Administration handbook.

The old page under HelpHub was removed as a consequence of Issue 795. But for some reason, if you use the old URL, it didn't re-direct properly, it re-directs to another page called "Optimization – Caching" because the title resembles "Optimization". And this page is just the "Caching" section of the "Optimization" page, so this page can be deleted as well.

The old URL now shows 404. The one in AAH is the right one.

However, the Optimization page on HelpHub appears to be working again now. Looks like it was reinstated?

#4 @sabernhardt
12 months ago

I get the 404 error in two browsers, including the one where I am logged in.

The URL is in the Site Health class file on lines 2519 and 2628.

#5 @Presskopp
12 months ago

I get the page only when I'm not logged in.

EDIT: While writing this, it seems the page came back from the grave.

Version 1, edited 12 months ago by Presskopp (previous) (next) (diff)

#6 in reply to: ↑ 3 ; follow-up: @audrasjb
12 months ago

Replying to SergeyBiryukov:

However, the Optimization page on HelpHub appears to be working again now. Looks like it was reinstated?

This page is currently a draft, so only user logged in as HelpHub editors can view its content. It goes to a 404 when you're not logged in :)

Last edited 12 months ago by audrasjb (previous) (diff)

#7 in reply to: ↑ 6 @SergeyBiryukov
12 months ago

Replying to audrasjb:

This page is currently a draft, so only user logged in as HelpHub editors can view its content.

Ah, indeed, that explains it. Thanks! :)

#8 @stevenlinx
12 months ago

I've restored the page.

See Doc Issue 872.

@SergeyBiryukov and @sabernhardt
Thanks for the ping.

#10 @audrasjb
12 months ago

  • Version 6.2.2 deleted

Ok, thanks!
If the URL is planned to be modified, it is not mandatory to wait for the next core release before updating but it would be nice to 1) redirect the old url; 2) keep this ticket open so we can update the url accordingly in the next release :)

Note: See TracTickets for help on using tickets.