Make WordPress Core

#58690 closed defect (bug) (duplicate)

Default value for parameter update_menu_item_cache

Reported by: crstauf's profile crstauf Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: docs Cc:

Description

The documentation for WP_Query::parse_query() indicates that the default value of the update_menu_item_cache parameter is false. However, the wp_get_nav_menu_items() function has the default value as true.

The documentation for wp_get_nav_menu_items() pulls the parameters documentation from WP_Query::parse_query(), which is contradictory to the function's definition.

I'm not sure what the correct fix is, or even what's appropriate.

Reported by @matmoe in User Contributed Notes.

Change History (3)

#1 @crstauf
11 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #55962.

#2 @audrasjb
11 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

This is probably a mistake @crstauf because #55962 looks very different :)
Reopening.

#3 @audrasjb
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Ok this is a duplicate of #58468.

Note: See TracTickets for help on using tickets.