Make WordPress Core

#58755 closed feature request (duplicate)

Concerning Re-usable Blocks

Reported by: warui1738's profile warui1738 Owned by:
Milestone: Priority: normal
Severity: minor Version: 6.2.2
Component: Taxonomy Keywords: dev-feedback reporter-feedback 2nd-opinion needs-design
Focuses: template, performance, coding-standards Cc:

Description

In my development of websites I have been using using re-usable blocks,they are very helpful and reduce the development time.The major problem is that when dealing with a very big site,you tend to be forgetful and you edit the re-usable block in a couple of pages and therefore you make significant change to the rest of the pages which uses the same block.

To solve this am suggesting a feature addition,where reusable blocks is:
1:Indepedent Reusable block: this block can be re-used but any change on it in any particular page will not affect its content on the re-usable blocks in other pages
2:Continous Reusable block: this block can be re-used but any change on it in any particular page will affect its content(like the current one) throughout the site

or

A pop over can be utilized asking the user whether he wants the re-usable block modified through out the site or the changes to remain in the page only where the re-usable has been modified

I know this can be done ,but people are very forgetful to uncheck modifying the re-usable block when saving and publishing pages

Change History (4)

#1 @pinksharpii
11 months ago

I've also experienced this issue. I think part of the problem is in the naming of "Reusable Blocks." They're not intended to be used how you think it sounds.
The solution that we have used, and I believe, the intended process is to use Patterns instead of Reusable Blocks. Patterns have to be declared in the theme, rather than by an editor in WordPress. But this will get you around the issue of overriding content on other pages.

#2 @wesatintellitonic
11 months ago

Something like this is already happening in the upcoming 6.3 release. "Reusable Blocks" and "Patterns" are being combined and re-named to "synced Patterns" and "un-synced Patterns".

There is also an effort underway to add "partially synced" patterns where the content (text, images) could be changed in each individual instance, but the design (e.g. section background color, columns) could be edited in one place for all instances of the pattern — I am not sure if this aspect is coming in 6.3 or if it has been punted to a future release.

Last edited 11 months ago by wesatintellitonic (previous) (diff)

#3 @joedolson
11 months ago

  • Focuses accessibility removed

#4 @mukesh27
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This ticket was indeed discussed during yesterday's Performance bug scrub.

The work has already been committed in version 6.3 through ticket #58577. If there are any pending tasks or if it is not yet completed, feel free to reopen the ticket to address them.

Additional props to @joemcgill.

Note: See TracTickets for help on using tickets.