Make WordPress Core

Opened 8 months ago

Closed 7 months ago

#58864 closed defect (bug) (reported-upstream)

Disambiguation by context

Reported by: alexclassroom's profile alexclassroom Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.3
Component: I18N Keywords: has-patch
Focuses: ui Cc:

Description

Bug Report

Description

It should be disambiguation by context if same word has multiple meanings

Environment

  • WordPress: 6.3-RC1-56269
  • PHP: 8.1.21
  • Server: nginx/1.24.0
  • Database: mysqli (Server: 10.6.14-MariaDB-1:10.6.14+maria~ubu2004 / Client: mysqlnd 8.1.21)
  • Browser: Edge 114.0.1823.82 (Windows 10/11)
  • Theme: Geologist 1.0.41
  • MU-Plugins: Not Active
  • Plugins:
    • Advanced WordPress Reset 1.7
    • Error Log Monitor 1.7.7
    • WordPress Beta Tester 3.5.2

Steps to Reproduce

  1. Go to Tools -> Import
  2. In zh_TW, this "Import" is similar to "Importer" (translate to "匯入程式"), but now it is merged and shares the exact translation "匯入" with the WordPress block editor's button.
  3. Please notice there is the same issue for "Author" (Sometimes means developer) and "Outline" (it has different meanings for web design and document) at least.

Expected Results

  1. UI string "Import", "Outline" and "Author" should be disambiguated by different meanings or content at least.

Actual Results

  1. UI string "Import", "Outline" and "Author" are not disambiguated.

Change History (12)

#1 @audrasjb
8 months ago

  • Component changed from General to I18N
  • Keywords changes-requested removed

#2 @audrasjb
8 months ago

  • Milestone changed from Awaiting Review to 6.3

Moving for 6.3 consideration as some of these strings were introduced in 6.3.

#3 @audrasjb
8 months ago

We can of course add translation context in WP Core strings, but it would probably be more relevant to add context to the block editor related strings as they are more recent than the core ones.

Pinging @isabel_brison as 6.3 Editor Tech Lead 🙂 what do you think?

#4 @isabel_brison
8 months ago

Is this a change we can still do during RC/string freeze? If so, I'm not opposed to it. Might be best to open an issue in Gutenberg with a description of what needs changing in which places.

This ticket was mentioned in Slack in #polyglots by peterwilsoncc. View the logs.


7 months ago

#6 @peterwilsoncc
7 months ago

I've shared a link to this ticket in the polyglots slack channel to ask for their advice/approval.

#7 @alexclassroom
7 months ago

Find the new word "Captions" should be disambiguation by context.

I think there are many words with the same issue, not only those listed in this ticket.

Whatever this issue is resolved, it's time to clean up it. It will be a long-term fight.

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


7 months ago

#9 @audrasjb
7 months ago

  • Keywords has-patch added; needs-patch removed

PR created upstream @isabel_brison: https://github.com/WordPress/gutenberg/pull/52907

#10 follow-up: @alexclassroom
7 months ago

The idea is to resolve this kind of issue.

  1. Create a script to scan the UI strings to meet the following conditions.

1.1. The number of the UI strings' characters is less than 15.
1.2. The UI strings are shared with many places. For example, Export, Import, Outline, Author, Captions, Scale, etc. As expected, more of the same will happen.

  1. Scan targets: WordPress Core from 5.0 to the latest version (Now is 6.3) and the latest Gutenberg (Now is 16.2).
  1. Then, we get a list that needs to be reviewed by humans. If the same English word has different meanings, this kind of word should be disambiguated by context.
  1. Update the locale language pack projects of WordPress 5.0 to the latest version.
  1. For Future WordPress Core and Gutenberg, run steps 1 to 4.

#11 in reply to: ↑ 10 @audrasjb
7 months ago

Replying to alexclassroom:

  1. Scan targets: WordPress Core from 5.0 to the latest version (Now is 6.3) and the latest Gutenberg (Now is 16.2).

I don't get this point: why backporting changes up to branch 5.0? The current version is the only version of WordPress officially maintained.

#12 @audrasjb
7 months ago

  • Milestone 6.3 deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

The above upstream PR has been merged by the Editor team.
I'm going to close this ticket as reported upstream since the issue will be fixed with a Gutenberg package update.

@alexclassroom I'd recommend to open a new ticket for the other issues so they can be considered for milestone 6.4.

Note: See TracTickets for help on using tickets.