WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#5888 closed defect (bug) (fixed)

No quicktags show up with RTE disabled

Reported by: Viper007Bond Owned by:
Milestone: 2.5 Priority: high
Severity: major Version: 2.5
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description

Dunno if this is just due to a WIP or if it's an actual bug, making a ticket just incase.

Go to your profile and disable TinyMCE. Visit the Write page and no quicktags show up. A TON of Javascript warnings do though.

Change History (4)

comment:1 @azaozz8 years ago

I've just tested this and it seems to work ok. No js warnings and tags show up as expected... Perhaps set your cache to 0 and restart the browser when changing TinyMCE settings to force it to update.

comment:2 @lloydbudd8 years ago

  • Priority changed from normal to high

ENV: WP Trunk r6883
Firefox 2

Confirmed bug. In one browser it is as you described. In another The RTE stayed. I tried refreshing my browser every which way.

comment:3 @azaozz8 years ago

I still can't reproduce this in FF... However think that found the reason (at least for the js errors). TinyMCE was still being added to the head even when disabled. The patch is in a different ticket: #5896, as I'm not sure if it fixes this as well. It also includes some other small updates and enhancements.

comment:4 @ryan8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6894]) TinyMCE config enhancements from azaozz. fixes #5896 #5888

Note: See TracTickets for help on using tickets.