Make WordPress Core

#58883 closed defect (bug) (reported-upstream)

Missing “general template parts”

Reported by: tomxygen's profile tomxygen Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.3
Component: Editor Keywords:
Focuses: Cc:

Description

In 6.3 RC1 if you go to Appearance > Editor > Patterns > Template Parts – General, no pattern is shown.

https://i.ibb.co/n7rXN6m/Screenshot-2023-07-23-at-4-03-39-PM.png

Attachments (2)

58883-screenshot-template-parts-wp63-gut.png (163.0 KB) - added by petitphp 10 months ago.
Screenshot of the site editor on the "Uncategorized" template-parts page
Capture d’écran 2023-08-01 à 15.40.23.png (247.1 KB) - added by audrasjb 10 months ago.
Fixed in RC2

Download all attachments as: .zip

Change History (8)

#1 @audrasjb
10 months ago

  • Component changed from General to Editor
  • Milestone changed from Awaiting Review to 6.3

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


10 months ago

#3 follow-up: @petitphp
10 months ago

After a quick search in Gutenberg repository's open issues, I didn't find anything that looks related to this bug.

Installing the latest version of Gutenberg with WP 6.3RC1 seem to fix the issue described, also the interface is not exactly the same ("General" category has been renamed to "Uncategorized" which match the area's name).

Last edited 10 months ago by petitphp (previous) (diff)

@petitphp
10 months ago

Screenshot of the site editor on the "Uncategorized" template-parts page

#4 in reply to: ↑ 3 @tomxygen
10 months ago

Replying to petitphp:

After a quick search in Gutenberg repository's open issues, I didn't find anything that looks related to this bug.

Installing the latest version of Gutenberg with WP 6.3RC1 seem to fix the issue described, also the interface is not exactly the same ("General" category has been renamed to "Uncategorized" which match the area's name).

I can't reproduce your screenshot in WP6.3RC1.
Just tried with a new install and the interface is exactly the same I posted earlier.

#5 @petitphp
10 months ago

I can't reproduce your screenshot in WP6.3RC1.
Just tried with a new install and the interface is exactly the same I posted earlier.

@tomxygen yes, the screenshot was made after I installed the latest version of Gutenberg to check if the issue had already been fixed by them. Which is the case.

I found the PR fixing the issue you have : https://github.com/WordPress/gutenberg/pull/52747

The fix should be available in the 6.3-RC2 :)

Last edited 10 months ago by petitphp (previous) (diff)

#6 @audrasjb
10 months ago

  • Milestone 6.3 deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Thanks for the ticket and welcome to WordPress Trac,

Indeed, I can't reproduce it anymore in RC2.
Closing this ticket as reported-upstream since it was fixed on Gutenberg's side.

Note: See TracTickets for help on using tickets.