Make WordPress Core

#58906 closed defect (bug) (duplicate)

Large amount of Users crashes the /wp-admin/users.php?action=delete page

Reported by: bedas's profile bedas Owned by:
Milestone: Priority: normal
Severity: major Version: 6.3
Component: Users Keywords:
Focuses: administration, performance Cc:

Description

Whenever a website has a large amount of users (in the testing case, 200k users), and you want to delete a user, the page at /wp-admin/users.php?action=delete completely crashes.

  1. Click delete for a certain user that has authored content or comments
  2. It will lead you to the /wp-admin/users.php?action=delete page
  3. There you can select if just delete or reassign content
  4. Choose to re-assign content and try to select a user to reassign to

At this point you will realise the page is completely crashed and un-reactive. Not even re-loading the page will work, it is completely boomed. If you open the console, you will see that not even the HTML inspector is capable to load, because something is blocking the entire browser.

I believe it is because the select provided to select a user to attribute to, is simply getting too large and it should be improved with a "search" (like select2), so not all users are loaded into the select at once.

This is simply not an ideal way to implement a select, it is not scalable, and it is very common for WP Websites to have a few more than a handful of users.
I cannot imagine I am the first one to notice and report this issue, yet, it seems there is no report mentioning this issue, at all.

I consider this a relatively urgent issue, because really out of 10 websites I manage, 9 websites have more than 1000 users. Perhaps I am alone with this.

The issue is on top very old.

Change History (2)

This ticket was mentioned in Slack in #meta by bedas. View the logs.


10 months ago

#2 @davidbaumwald
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

@bedas Thanks for the ticket! This is being tracked in #19867. I see it was attempted to mark this as a duplicate, but it didn't go through. Doing that now.

Note: See TracTickets for help on using tickets.