Make WordPress Core

#58913 closed defect (bug) (worksforme)

Button Overlap Issue in French and Other Languages.

Reported by: truptikanzariya's profile truptikanzariya Owned by: audrasjb's profile audrasjb
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-screenshots close
Focuses: ui, css, administration Cc:

Description

The issue is that the Gutenberg block post button 'Switch to Draft' and 'Move to Trash' overlap in French and other Languages.

Screenshots: https://prnt.sc/_-TMYexP_rJv

Attachments (2)

Capture d’écran 2023-07-26 à 15.56.39.png (206.1 KB) - added by audrasjb 10 months ago.
Can't reproduce on WP 6.3 RC2
Google-Translate-6.3.png (40.3 KB) - added by sabernhardt 10 months ago.
sidebar in WP6.3RC1, using Google Translate Chrome extension

Download all attachments as: .zip

Change History (9)

#1 @audrasjb
10 months ago

  • Keywords reporter-feedback added
  • Owner set to audrasjb
  • Status changed from new to reviewing

Hello and welcome to WordPress Core Trac @truptikanzariya!

Which version of WordPress are you using? And which Locale/translation.
I don't have the same interface (no bug on my side) and I don't have the same translations in my fr_FR install.

Thanks for the info!

(see screenshot below)

@audrasjb
10 months ago

Can't reproduce on WP 6.3 RC2

#2 @audrasjb
10 months ago

It doesn't look like an official French translation, since for example "Post" should not be translated into "Poste" but rather into "Article". Same goes with other strings that are poorly translated in your screenshot.

#3 @NekoJonez
10 months ago

I tested this with my locale on which I'm GTE. nl_BE (Dutch - Belgium) and I tried to resize my browser window on Firefox & Opera... And I can't reproduce either.
Which setup do you have? Any other plugins running?
What theme?

I use WP6.3 RC2 via the beta tester & LocalWP.

#4 @audrasjb
10 months ago

  • Keywords needs-patch removed

#5 @truptikanzariya
10 months ago

Hello,

I have Google translated this page, and this has caused this problem.

https://prnt.sc/aS8gAraqG0sL

#6 @audrasjb
10 months ago

  • Keywords close added; reporter-feedback removed

Alright, that explain why the translations were incorrect :)

Google translate probably inject its translation directly to the DOM without repainting it.

I'm not sure we can really fix this behavior.

Look at the screenshot I shared earlier: the interface looks responsive and the buttons adapt to their content. But when the strings are replaced without any repaint, I guess it doesn't work 🤷‍♂️

@sabernhardt
10 months ago

sidebar in WP6.3RC1, using Google Translate Chrome extension

#7 @sabernhardt
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reviewing to closed

The buttons stacked for me, even when using the Google Translate extension, so I'll close this.

If this (or another aspect of the editor sidebar) does need fixing, the report would belong on the Gutenberg GitHub Repository.

Note: See TracTickets for help on using tickets.