Make WordPress Core

Opened 10 months ago

Closed 7 months ago

#58915 closed defect (bug) (fixed)

Twenty Thirteen and Twenty Sixteen: change display for the summary element in Details blocks

Reported by: sabernhardt's profile sabernhardt Owned by: peterwilsoncc's profile peterwilsoncc
Milestone: 6.4 Priority: normal
Severity: normal Version: 6.3
Component: Bundled Theme Keywords: has-patch has-testing-info has-screenshots commit
Focuses: css Cc:

Description

Both Twenty Thirteen and Twenty Sixteen set the summary element to display: block in the Reset/Normalize section of their stylesheets. When using the Details block, this removes or hides the toggle triangle native to the browser.

Other default themes:

  • Twenty Seventeen, Twenty Nineteen and Twenty Twenty-One set the summary to list-item display.
  • The other eight themes rely on the browser's native display styling.

Attachments (5)

details-block-2013-editor.png (8.8 KB) - added by sabernhardt 10 months ago.
Details block in the editor, with Twenty Thirteen
details-block-2013-front.png (20.1 KB) - added by sabernhardt 10 months ago.
Details block on the front end, without a marker, using Twenty Thirteen
details-block-2016-editor.png (7.6 KB) - added by sabernhardt 10 months ago.
Details block in the editor, using Twenty Sixteen
details-block-2016-front.png (6.3 KB) - added by sabernhardt 10 months ago.
Details block on the front end, without a marker, using Twenty Sixteen
58915.patch (1.1 KB) - added by sabernhardt 10 months ago.
adds list-item specifically for the (first) summary element in a Details block

Download all attachments as: .zip

Change History (14)

@sabernhardt
10 months ago

Details block in the editor, with Twenty Thirteen

@sabernhardt
10 months ago

Details block on the front end, without a marker, using Twenty Thirteen

@sabernhardt
10 months ago

Details block in the editor, using Twenty Sixteen

@sabernhardt
10 months ago

Details block on the front end, without a marker, using Twenty Sixteen

@sabernhardt
10 months ago

adds list-item specifically for the (first) summary element in a Details block

#1 @sabernhardt
10 months ago

  • Keywords has-patch added

Removing summary from the normalized styles would be easier, but some people may have created a custom toggle marker that works with the block display for a details element (not using the new WordPress block).

#2 @poena
9 months ago

  • Milestone changed from Awaiting Review to 6.3.1

I have tested patch 58915.patch manually on macOS in various browsers, and it works well for me.

#3 @Ankit K Gupta
9 months ago

Test Report

Patch tested: https://core.trac.wordpress.org/attachment/ticket/58915/58915.patch

Env

  • WordPress - 6.4-alpha-20230819.191300
  • Web Server: Nginx
  • Chrome Version - 115
  • OS - macOS
  • Theme: Twenty-Thirteen, Twenty-Sixteen
  • PHP - 7.4.0
  • Active Plugin - None

Test result ✅

The purpose of this testing was to assess the behavior of the arrow icon within the details block across two default WordPress themes: Twenty-Sixteen and Twenty-Thirteen. The testing aimed to verify if the arrow icon correctly appears as intended in revealing and concealing the additional content within the details block.

The toggle arrow icon works fine after the patch in the editor as well as the front end.

After the patch-

Twenty Thirteen:

https://i.imgur.com/ag7Efo7.jpg

Twenty Sixteen:

https://i.imgur.com/Wv9WWi9.jpg

#4 @Ankit K Gupta
9 months ago

  • Keywords has-testing-info has-screenshots added

#5 @audrasjb
9 months ago

  • Milestone changed from 6.3.1 to 6.3.2

WP 6.3.1 is going to be released in the next few days, so let's move this ticket to 6.3.2 to give it more time to be committed and backported.

#6 @sabernhardt
8 months ago

  • Milestone changed from 6.3.2 to 6.4

#7 @nicolefurlan
8 months ago

@poena I'm checking on some tickets in the 6.4 milestone to make sure we're ready for RC1 in ~2 weeks. It looks like this ticket has passing test reports. Do you think this is ready for a commit? Would you like to take ownership and usher it through? :)

#8 @poena
8 months ago

  • Keywords commit added

Yes, I think it is ready.

#9 @peterwilsoncc
7 months ago

  • Owner set to peterwilsoncc
  • Resolution set to fixed
  • Status changed from new to closed

In 56940:

Twenty Thirteen, Twenty Sixteen: Use default display for summary element.

Within the details block, style the summary element using the default display, list-item, this ensures the toggle icon appears indicating the summary can be expanded or contracted.

Props ankit-k-gupta, nicolefurlan, poena, sabernhardt.
Fixes #58915.

Note: See TracTickets for help on using tickets.