Make WordPress Core

Opened 7 months ago

Closed 7 months ago

#58928 closed defect (bug) (duplicate)

PHP 8.1 and higher

Reported by: roundaboutweb's profile roundaboutweb Owned by:
Milestone: Priority: normal
Severity: critical Version: 6.2.2
Component: General Keywords:
Focuses: Cc:

Description

Security support for PHP 8.0 will end in November 2023. However, WordPress itself still recommends PHP 7.4 and has still only defined all 8 versions as beta.

When can we expect WordPress to finally officially support current PHP versions?

The problem:
WordPress itself seems to work flawlessly with 8.1 and 8.2, but many plugins do not and the manufacturers always refer to the WordPress version below:
https://make.wordpress.org/core/handbook/references/php-compatibility-and-wordpress-versions/

Change History (1)

#1 @SergeyBiryukov
7 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, welcome to WordPress Trac! Thanks for the ticket.

We're already tracking this in #58320, let's continue the discussion there.

Note: See TracTickets for help on using tickets.