Make WordPress Core

Opened 11 months ago

Closed 9 months ago

Last modified 9 months ago

#58947 closed enhancement (fixed)

Add event type to dashboard WordPress Events and News widget

Reported by: renyot's profile renyot Owned by: audrasjb's profile audrasjb
Milestone: 6.4 Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch has-screenshots commit
Focuses: Cc:

Description

In this PR, the event type was introduced to community/events and community/events/online before the event location for better identification.

And as per the feedback from the meta-wordcamp channel and the PR comment, the adding of the event type to dashboard makes the display consistent and provides a good additional info for the audience.

Attachments (3)

Markup on 2023-07-31 at 23:34:45.png (147.5 KB) - added by renyot 11 months ago.
58947.diff (1.2 KB) - added by dhruvishah2203 10 months ago.
2023-09-17_22-24-06.png (20.2 KB) - added by oglekler 9 months ago.
Test of https://core.trac.wordpress.org/attachment/ticket/58947/58947.diff

Download all attachments as: .zip

Change History (23)

#1 @renyot
11 months ago

  • Type changed from defect (bug) to enhancement

This ticket was mentioned in PR #4941 on WordPress/wordpress-develop by @renyot.


11 months ago
#2

  • Keywords has-patch added

#3 @renyot
11 months ago

  • Keywords has-screenshots needs-testing added

#4 @audrasjb
11 months ago

  • Milestone changed from Awaiting Review to 6.4
  • Owner set to audrasjb
  • Status changed from new to reviewing

Hello and welcome to WP Core Trac!

Thanks for the ticket and patch. Looks good to me at a glance. Moving to milestone 6.4 and self assigning for review.

#5 @renyot
11 months ago

Hello 👋 Thanks for the help!

#6 @dhruvishah2203
10 months ago

  • Keywords needs-testing-info added

#7 @Ankit K Gupta
10 months ago

Thank you, @renyot, for this suggestion and patch. This enhancement is highly beneficial, and I personally appreciate it.

I got an opportunity to test the patch, and it is functioning as expected.

Test Report. ✅

Patch tested: https://github.com/WordPress/wordpress-develop/pull/4941

Env

  • WordPress - 6.4-alpha-20230824.164623
  • Web Server: Nginx
  • Chrome Version - 115
  • OS - macOS
  • Theme: Twenty Sixteen Version: 3.0
  • PHP - 7.4.0
  • Active Plugin - None

Steps to Test

  1. Login to WordPress Dashboard
  2. Enable the WordPress Events and News section from Screen Option IF not enabled
  3. Verify event type appears before the location
  4. Change the location and confirm the event type should appear.


Test result

This new enhancement works as expected and is very useful for users to easily identify the type of event.

During this test, the patch performed as expected, and I didn't encounter any regressions. I conducted a quick test by changing the location in this widget as well and found all actions working as expected.

Status

Ready to Next Step.✅

Before the patch-

https://i.imgur.com/6NmW4pe.jpg

After the patch-

https://i.imgur.com/y6zFcMr.jpg

Last edited 10 months ago by Ankit K Gupta (previous) (diff)

#8 @Ankit K Gupta
10 months ago

  • Keywords needs-testing needs-testing-info removed

#9 @oglekler
9 months ago

As you can see on the screenshot above, we have a lot of repeated words, and in case of an event in the middle, we end up with two identical lines. We may need some feedback from designers.

Last edited 9 months ago by oglekler (previous) (diff)

#10 @oglekler
9 months ago

  • Keywords needs-design-feedback added

#11 @devmuhib
9 months ago

Test Report

Patch Works Fine.

Patch tested: https://core.trac.wordpress.org/attachment/ticket/58947/58947.diff

Environment

OS: Window 10
Web Server: nginx/1.25.2
PHP: 7.4.33
WordPress: 6.4-alpha-56267-src
Browser: Google Chrome
Theme: Twenty-Twenty-Four

Actual Results

  • ✅ Display the event type like (Meetup and Wordcamp etc)

Supplemental Artifacts

Before Applying the Patch: https://i.imgur.com/cYJD7IK.png

After Applying the Patch: https://i.imgur.com/jL8qEAS.png

Last edited 9 months ago by devmuhib (previous) (diff)

#12 @JeffPaul
9 months ago

@oglekler your tests appear to have events that aren't uniquely named and thus appear to have the appearance of duplicate information. With the rest of the examples folks have provided, the additional clarity on the second line does appear more helpful. As such, I'm inclined to think this is a helpful change in the scenarios where the text is different and at worst just duplicate text where the text is the same/extremely similar.

#13 @anveshika
9 months ago

Test Report

Patch used- https://github.com/WordPress/wordpress-develop/pull/4941

Testing Environment-

  • WordPress - 6.4 dev version
  • Web Server: Apache
  • OS - Windows 10
  • Theme: Twenty Twenty Two
  • PHP - 7.4.0

Test result

The PR works as expected. Didn't find any UI/UX issue after using the PR. ✅

Screenshot attached:

https://i.imgur.com/SG0IwVR.jpg

https://i.imgur.com/Eo6rIKn.jpg

#14 @oglekler
9 months ago

  • Keywords commit added; needs-design-feedback removed

We have plenty of tests and if everyone ok with possible text duplication, I assume it can be reviewed for commit.

#15 @JeffPaul
9 months ago

I'm getting some reviews from others to see if they feel the event type information/location is helpful in this... will work to get their feedback by end of Monday. So hopefully that commit can hold off until then as I work to validate.

#16 @sarahwilliams889
9 months ago

Without some other forcing function to require the event type to be defined in the event title, the additional event type and location line is helpful. I think the benefits outweigh the risk of duplicative text.

#17 @ajakaroth
9 months ago

In cases where the event type is already included in the title, is there a way to identify this and then not show the event type in the location line to avoid the duplication?

#18 @peterwilsoncc
9 months ago

I think with the separator between the event type and location the potential duplication is worthwhile.

The online indicator is very helpful in cities in which Meetups and WordCamps are still to return due to the pandemic.

In cases where the event type is already included in the title, is there a way to identify this and then not show the event type in the location line to avoid the duplication?

It may be helpful to fine tune this but I think there's a risk of making the perfect the enemey of the good to delay furhter.

#19 @peterwilsoncc
9 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 56697:

Administration: Add event type to Events and News widget.

Add the event type (WordCamp, Meetup, etc) to the nearby events listing within the Dashboard's Events and News widget.

Props renyot, audrasjb, ankit-k-gupta, oglekler, devmuhib, dhruvishah2203, JeffPaul, anveshika, sarahwilliams889, ajakaroth.
Fixes #58947.

Note: See TracTickets for help on using tickets.