Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#59044 closed defect (bug) (duplicate)

the_excerpt() function return excerpt with different length in page load and ajax request on WordPress 6.3

Reported by: sarathlal's profile sarathlal Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.3
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

I'm using the_excerpt() function in a post loop that display posts from a custom WP query for "Post" post type. Using the same query with pagination parameter and same post loop to display more posts using AJAX.

Recently I noticed that the excerpt length was different on page load & AJAX load. I think, it's started after updating to WordPress 6.3. Another user also raised a related support thread in support forum.

https://wordpress.org/support/topic/unexpected-behavior-in-post-loop-after-sending-ajax-request/

Change History (2)

#1 @sarathlal
8 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #59043.

#2 @SergeyBiryukov
8 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.