Make WordPress Core

Opened 6 months ago

Last modified 6 months ago

#59104 new defect (bug)

duotone is not applied to videos in the cover block in safari

Reported by: kiandept's profile kiandept Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 6.3
Component: Editor Keywords: needs-patch
Focuses: Cc:

Description

Dear Team,

duotone (svg filter) is not applied to videos in cover block in safari (screenshot safari). In edge for example it works (screenshot ms edge).

I would be very happy about a solution.

Many greetings
Kiril

Change History (5)

#1 @kiandept
6 months ago

Can someone please help me delete the screenshots? I just wanted to post an excerpt.

#2 @sabernhardt
6 months ago

  • Component changed from Media to Editor

Hi and welcome to WordPress Trac!

The screenshots are deleted at your request.

This probably will need an issue in the Gutenberg repository. Would you like to create one?
https://github.com/WordPress/gutenberg/issues/new/choose

Also, did the duotone filter work with video in a Cover block when using Safari and WordPress 6.2?

#3 @ajlende
6 months ago

@kiandept Which version of Safari are you using? We removed a workaround for a Safari bug that is now fixed in the versions Safari that we officially support, the latest two versions.

#4 @kiandept
6 months ago

@sabernhardt thanks for deleting the pictures and the quick feedback. Of course I can create an issue in the Gutenberg repository. No problem. Yes, the problem also exists under wordpress 6.2

@ajlende thanks for the info! tested on iOS 16.6, Twenty Twenty-ThreeVersion: 1.2, tested on wordpress 6.2 and 6.3

When cross-checking with an image, the filter is applied. It would be great if someone could check the error and reproduce it.

#5 @ajlende
6 months ago

I did some more investigation and was able to reproduce the issue. I wonder if, in fixing some SVG issues in Safari 16.4, they ended up breaking SVG filters on video.

Unfortunately I wasn't able to find a workaround for now. I found WebKit Bug 184601 that looks like our issue. The issue was opened before duotone was introduced, but I distinctly remember it working previously because I was annoyed with the poor performance in Safari, so maybe it isn't the right one.

Note: See TracTickets for help on using tickets.