Make WordPress Core

#59258 closed defect (bug) (duplicate)

Some block styles not loading in 6.3.1

Reported by: mmcalister's profile mmcalister Owned by: joemcgill's profile joemcgill
Milestone: Priority: normal
Severity: normal Version: 6.3.1
Component: Editor Keywords:
Focuses: Cc:

Description

On some new WordPress installs with block themes, core styles for the navigation and other blocks are not loading.

https://olliewp.com/wp-content/uploads/2023/08/Screenshot-2023-08-30-at-10.31.50-PM.png

https://olliewp.com/wp-content/uploads/2023/08/IMG_20230830_131936_01.jpg

This is happening on some fresh installs on live sites (screenshot above is from a fresh InstaWP install), but I can't replicate on local dev environments.

A friend initially reached out with this error a few days ago on his site using TwentyTwentyTwo. After troubleshooting for hours, I had no fix for it. Then, last night, I saw this same issue with my own theme on an entirely different server.

When I switch back to 6.3, this issue is not present.

This is a hard one to reproduce, but you can see live on this temporary theme demo: https://eeable-ape-xaho.instawp.xyz/. If you want to create a site and experience the issue live, go to this theme demo site and create an admin theme demo: https://demo.olliewp.com/live-demo/

Go through the setup wizard and click through the steps to create some pages. You'll be able to see the issue at the end of the wizard when you view the site.

Attachments (2)

Screenshot 2023-08-30 at 10.31.50 PM.png (132.8 KB) - added by mmcalister 11 months ago.
Preview of the issue
IMG_20230830_131936_01.jpg (95.0 KB) - added by mmcalister 11 months ago.
Preview of the issue

Download all attachments as: .zip

Change History (5)

@mmcalister
11 months ago

Preview of the issue

@mmcalister
11 months ago

Preview of the issue

#1 @joemcgill
11 months ago

  • Owner set to joemcgill
  • Status changed from new to reviewing

Hi @mmcalister and welcome to Trac! I suspect you're running into the same issue described in #59111, though the version difference from 6.3.0 to 6.3.1 is a new detail. Would you mind trying to add the following line to the wp-config.php file for that site and see if your problem goes away?

define( 'WP_DEVELOPMENT_MODE', 'core' );

#2 @mmcalister
11 months ago

Hi @joemcgill. Thanks for the quick response! That did indeed fix the issue on that site. As you can see, the site appears as it should now: https://eeable-ape-xaho.instawp.xyz/

Looks like this may be a duplicate of that existing issue. If so, we can close this up. Thanks again!

#3 @joemcgill
11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reviewing to closed

Duplicate of #59111.

Thanks for confirming! I'm going to close this as duplicate and add your specific details to the other ticket so we can make sure we account for your use case in the eventual fix. Feel free to participate in the conversation in that ticket.

Note: See TracTickets for help on using tickets.