Make WordPress Core

Opened 6 months ago

Closed 5 months ago

Last modified 4 weeks ago

#59290 closed enhancement (duplicate)

HTML API: Expose raw tag markup to support existing filters

Reported by: dmsnell's profile dmsnell Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4
Component: HTML API Keywords: has-patch
Focuses: Cc:

Description

Many existing filters in Core (e.g. wp_targeted_link_rel) pass segments of the raw HTML markup for matched tags where code implementing those hooks perform futher analyis on those segments. The HTML API attempts to hide the raw inner markup as much as possible, making it hard to provide full backwards compatability with these existing filters.

In this patch a new function is added which extracts the raw markup to maintain those existing behaviors. It requires a disclaimer to operate to try and encourage folks to use the structural and semantic methods provided by the HTML API.

Where possible, existing code and filters should be updated so that they no longer depend on the raw HTML.

Change History (2)

#1 @dmsnell
5 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #59291.

Not sure how I created this, but it was mistakenly created.

#2 @swissspidy
4 weeks ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.