Make WordPress Core

Opened 10 months ago

Closed 2 months ago

#59298 closed defect (bug) (worksforme)

Twenty Fourteen : search block is having issue with alignment.

Reported by: nidhidhandhukiya's profile nidhidhandhukiya Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.3.1
Component: Bundled Theme Keywords: reporter-feedback close
Focuses: Cc:

Description

Steps to reproduce the issue :-

  1. Activate Twenty Fourteen theme.
  2. Choose Search block.
  3. Apply center align and check in front side.
  4. Apply Right align and then check in front side.

You can able to see that center aligned is having issue.
I have attached video for better understanding.
Video URL :- https://share.cleanshot.com/6p3TmBFwZ91llFT5V52R

Change History (4)

#1 @nidhidhandhukiya
10 months ago

  • Summary changed from Twenty Forteen : search block is having issue with alignment. to Twenty Fourteen : search block is having issue with alignment.

#2 @sabernhardt
10 months ago

  • Keywords reporter-feedback added

Did you set a special width on the centered Search block? It looks like it might be 75%.

Because the custom width is set on the .wp-block-search__inside-wrapper container instead of the entire block, the Search label does not either center or line up with the edge of a centered Search block in any of the bundled themes except for Twenty Twenty-One. GB30444 was tested with that theme, which centers any text inside an element with aligncenter.

I do not think editing individual themes for this would help. You could open a Gutenberg issue to consider center-aligning the text (label) for all centered Search blocks.

#3 @karmatosed
3 months ago

  • Keywords close added

I am going to agree with @sabernhardt here that I don't think that I see the issue. This might be that I am missing a step to reproduce though @nidhidhandhukiya and please share if that is the case and you are still experiencing this without having any special width on the centered search block.

Presuming that it no longer is an issue I am going to add the close keyword. This still allows time for feedback in the case that there are further steps to reproduce though. Thank you everyone for your collaboration.

#4 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

For now, I am going to close this as it has waited for feedback for a little while with this keyword. Thank you everyone.

Note: See TracTickets for help on using tickets.