Make WordPress Core

Opened 9 months ago

Closed 8 months ago

#59333 closed defect (bug) (reported-upstream)

Link Issues

Reported by: vvt10551's profile vvt10551 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.3.1
Component: Permalinks Keywords: close
Focuses: Cc:

Description

Hello,

Summation: Code and/or plugin needed to remove rel="noreferrer noopener" from links.

Detailed Issue:

Opening links in new tab/window refrains interruption of the content being read, viewed, and/or listened to.

And it is recommended to open new tabs/windows more often than not, e.g. losing reading position, interrupting AI readers, etc. Yes, it is safe to open new tab/window via _blank, additionally, it isn’t black hat, and does not carry pessimistic tendencies, as well as reference for page rank, not talking about uninterrupted SEO of direct traffic. Aforementioned is important because only 4.1 billion people use the internet, about 56.7 of global population, therefore knowing a reference is important.

How can this be remedied, by removing rel="noreferrer noopener"?

rel="noreferrer noopener" is added automatically, it is re-added (after being removed) upon saving/publishing.

Is there a code and/or plugin that works and does this?

There are references of code for functions.php and plugins that haven’t been updated in years. Code does not work, and we’re reluctant to use the outdated plugins.

Not window.opener.location issue.

Looking forward to having this resolved.

Thank you in advance.

Best regards.

Change History (5)

#1 follow-up: @spacedmonkey
9 months ago

  • Focuses accessibility performance privacy sustainability coding-standards removed
  • Severity changed from critical to normal

You consider looking into [44714].

#2 in reply to: ↑ 1 @vvt10551
9 months ago

  • Severity changed from normal to major

Replying to spacedmonkey:

You consider looking into [44714].

Thank you for your response,

It looks like phpunit needs to be created from scratch in reference to phpunit/tests/formatting/WPTargetedLinkRel.php

Nothing in WP, phpunit is in plugins mainly, unless all 3 directory files are edited from 44714, and a new one created (phpunit) and where? this does not matter, as long as it is already implemented. Not doing this for live site, or creating staging site where if robots.txt is not added properly SEO ranking is penalized via duplicates by being removed from search engines, a huge violation to search engines (duplicates), but that's something else in regards to stage sites.

Is this being added to upcoming WP update? This current link code does more harm than good, it can be confirmed via Google analytics 4, referrers cannot be seen with no opener, and is being re-added upon removal every time post/page is saved.

Not only is the functions.php code being shared (in search, github, and on) does not work, it does not address rel=”noopener”. All this contributes to white screen of death (WOD). Not the main issue.

By modifying, and adding new files can conflict with upcoming WP versions from our end.

Mainly checking in on this issue being addressed, as aforementioned in the initial ticket. This isn't a hard fix, however currently it harms page rank, and domain rank by adding rel=”noreferrer noopener”.

There needs to be a permanent solution, because anyone can add rel=”noreferrer noopener” if they'd like, not the other way around.

Thank you for your understanding.

#3 @vvt10551
9 months ago

  • Focuses accessibility performance sustainability coding-standards added
  • Severity changed from major to critical

This impacts the entire wordpress opensource, and should be addressed respectively, and enhanced with either WP plugin, and/or the next WP update.

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


8 months ago

#5 @joedolson
8 months ago

  • Focuses accessibility performance sustainability coding-standards removed
  • Keywords close added
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Severity changed from critical to normal
  • Status changed from new to closed

This is already an open issue on Gutenberg: https://github.com/WordPress/gutenberg/issues/26914, and should be discussed there.

Note: See TracTickets for help on using tickets.