Make WordPress Core

Opened 8 months ago

Closed 7 months ago

#59437 closed defect (bug) (fixed)

When I open the site editor in WordPress 6.4 + TT4, I get multiple Block validation failed.

Reported by: nendeb55's profile nendeb55 Owned by:
Milestone: 6.4 Priority: normal
Severity: critical Version: 6.4
Component: Themes Keywords:
Focuses: Cc:

Description

blocks.min.js?ver=b5d3b99262dfb659bd26:10 Block vali dation: Block vali dation failed for `core/details` (Object).
blocks.min.js?ver=b5d3b99262dfb659bd26:10 Block vali dation: Block vali dation failed for `core/heading` (Object).

https://nendeb.com/wp-content/uploads/tt4_err_02.jpg

Also, the public page is out of order.
https://nendeb.com/wp-content/uploads/tt4_err_01.jpg

Core : WordPress 6.4-alpha-56670
Theme : Twenty Twenty-Four
Plugin : none
PHP : 8.0.28

Other conditions

  1. If you change only Core to WordPress6.3 under the same conditions, it works fine.
  2. Under the same conditions, if only Theme is changed to Twenty Twenty-Three, it works normally.

https://nendeb.com/wp-content/uploads/tt4_err_02.jpg

Also, the public page is out of order.
https://nendeb.com/wp-content/uploads/tt4_err_01.jpg

Core : WordPress 6.4-alpha-56670
Theme : Twenty Twenty-Four
Plugin : none
PHP : 8.0.28

Other conditions

  1. If you change only Core to WordPress6.3 under the same conditions, it works fine.
  2. Under the same conditions, if only Theme is changed to Twenty Twenty-Three, it works normally.

Attachments (2)

Cannot reproduce - Chrome.png (366.7 KB) - added by hellofromTonya 7 months ago.
Test Report: Cannot reproduce reported issue with 6.4 RC2 (on Chrome)
Cannot reproduce - Firefox.png (461.0 KB) - added by hellofromTonya 7 months ago.
Test Report: Cannot reproduce reported issue with 6.4 RC2 (on Firefox)

Download all attachments as: .zip

Change History (10)

#1 @nendeb55
8 months ago

Sorry, I wrote double on the content.

#2 @wildworks
8 months ago

Thanks for the report.

WordPress 6.4 Alpha does not yet bundle the Gutenberg version that will be implemented in WordPress 6.4. However, since Twenty Twenty-Four is based on the Gutenberg version implemented in WordPress 6.4, this error probably occurs.

My guess is that these errors will be resolved when WordPress 6.4 beta 1 is released or by installing the Gutenberg plugin.

For example, regarding errors in the Details block, this Gutenberg PR may be relevant. This PR is not implemented in WordPress 6.4 alpha.

https://github.com/WordPress/gutenberg/pull/49808

#3 @nendeb55
8 months ago

Hi @wildworks

Thanks for the reply.

I will double check with WordPress 6.4 beta.

#4 @nendeb55
8 months ago

Tried with WordPress 6.4-beta1-56730.
The error is still there but less than the other day.
I hope this will be resolved in future updates.

By the way
I also tried with WordPress 6.3.1, but this one is giving a lot of errors.
Twenty Twenty-Four says in style.css that it can be used from WordPress6.2, but is it ok?

blocks.min.js?ver=b5d3b99262dfb659bd26:10 Block validation: Expected attribute `style` of value `aspect-ratio:3/2;object-fit:contain`, saw `aspect-ratio:3/2;object-fit:contain;width:150px`.
blocks.min.js?ver=b5d3b99262dfb659bd26:10 Block validation: Block validation failed for `core/image` ({name: 'core/image', icon: {…}, keywords: Array(3), attributes: {…}, providesContext: {…},?…}).
blocks.min.js?ver=b5d3b99262dfb659bd26:10 Block validation: Block validation failed for `core/image` ({name: 'core/image', icon: {…}, keywords: Array(3), attributes: {…}, providesContext: {…},?…}).
blocks.min.js?ver=b5d3b99262dfb659bd26:10 Block validation: Block validation failed for `core/details` ({name: 'core/details', icon: {…}, keywords: Array(3), attributes: {…}, providesContext: {…},?…}).
blocks.min.js?ver=b5d3b99262dfb659bd26:10 Block validation: Expected text `Details`, saw `Who is behind Etudes?`.
blocks.min.js?ver=b5d3b99262dfb659bd26:10 Block validation: Expected text `Details`, saw `Can I apply to be a part of the team or work as a contractor?`.
 .
 .
 .

Core : WordPress 6.3.1
Theme : Twenty Twenty-Four(WordPress 6.4-beta1 included)
Plugin : none
PHP : 8.0.28

@hellofromTonya
7 months ago

Test Report: Cannot reproduce reported issue with 6.4 RC2 (on Chrome)

@hellofromTonya
7 months ago

Test Report: Cannot reproduce reported issue with 6.4 RC2 (on Firefox)

#5 @hellofromTonya
7 months ago

Reproduction Report

This report validates that the issue can be reproduced.

Environment

  • OS: macOS 13.2.1
  • Web Server: Nginx
  • PHP: 8.0.30
  • WordPress: 6.2 RC2
  • Browser: Chrome and Firefox
  • Theme: Twenty Twenty-Four (TT4)
  • Active Plugins: none

Actual Results

  • ❌ Unable to reproduce the block validation errors in the Site Editor.

Supplemental Artifacts

Tested in Chrome - see Cannot reproduce - Chrome.png

Tested in Firefox - see Cannot reproduce - Firefox.png

#6 @hellofromTonya
7 months ago

  • Keywords reporter-feedback close added

Hello @nendeb55,

Welcome to WordPress Core's Trac :)

I too am unable to reproduce the block validation errors in the Site Editor.

Can you retest please using 6.4 RC2?

I'll mark this ticket as a close candidate, pending reporter-feedback. It is possible something wasn't yet fixed or merged during beta when the issue was first reported.

Twenty Twenty-Four says in style.css that it can be used from WordPress6.2, but is it ok?

Twenty Twenty-Four requires WP 6.4.

#7 @nendeb55
7 months ago

Hellow @hellofromTonya

WordPress 6.4 RC2 did not have block validation errors in the site editor

This seems to have been resolved in WordPress 6.4 RC2, so please close.

Thanks.

#8 @hellofromTonya
7 months ago

  • Keywords reporter-feedback close removed
  • Milestone changed from Awaiting Review to 6.4
  • Resolution set to fixed
  • Status changed from new to closed

That's good news 🎉 Thanks for confirming @nendeb55

Though unsure which changeset resolved the issue, marking this ticket as fixed.

Note: See TracTickets for help on using tickets.