Make WordPress Core

Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#5945 closed defect (bug) (fixed)

Switching from Visual to HTML editor crashes Safari

Reported by: douglsmith's profile douglsmith Owned by: azaozz's profile azaozz
Milestone: 2.5 Priority: high
Severity: blocker Version: 2.5
Component: TinyMCE Keywords: safari crash tinymce visual
Focuses: Cc:

Description

In the Safari browser, if you type a few characters in the post area of the visual editor, then click the button to switch to HTML, Safari crashes.

If you switch to HTML mode with no text in the post, it works fine. You can then enter some text and switch back and forth with no problem. If you change any of the text in Visual mode then try switching to HTML, it will crash.

I was able to reproduce this with:

  • Safari 3.04 (5523.15) (current Leopard version) on Mac OS 10.5.2
  • Safari 3.04 (523.12.2) (current Tiger version) on Mac OS 10.4.11

It did not crash with:

  • a recent Webkit nightly build on Mac OS 10.5.2
  • Safari 3.04 beta for Windows on XP

I'll attach my Mac crash log to the ticket.

Attachments (1)

crashlog.txt (30.4 KB) - added by douglsmith 14 years ago.
Mac Safari crash log

Download all attachments as: .zip

Change History (8)

@douglsmith
14 years ago

Mac Safari crash log

#1 @ryan
14 years ago

Confirmed with the recent TinyMCE 3.01 update on Safari 3.04 on Leopard.

#2 @ryan
14 years ago

  • Owner changed from anonymous to azaozz

#3 @azaozz
14 years ago

I can confirm it's working fine in Safari XP 3.0.4 (523.15 - latest beta for win). Can you download TinyMCE and see if it crashes in the examples there too:
http://tinymce.moxiecode.com/download.php

especially in the "Full featured" one (you can use the Show/Hide links on the bottom to emulate switching to HTML mode in WordPress).

Could you also submit this on TinyMCE's bugs tracker:
http://sourceforge.net/tracker/?group_id=103281&atid=635682

and perhaps on WebKit's tracker too:
http://webkit.org/quality/reporting.html

#4 @douglsmith
14 years ago

I have confirmed that this also happens with the TinyMCE full.html example in the download. If you make any change to the text then click the Hide link, Safari crashes.

I'll submit it to TinyMCE's bug tracker shortly.

I did not submit it to the WebKit tracker because the page text indicates it's only for reports of bugs that occur in the current build of WebKit. Recent nightly builds of WebKit I've tried are not subject to this problem. However, I did submit a full report to Apple through the crash reporter on my Mac.

#5 @ryan
14 years ago

  • Severity changed from critical to blocker

#6 @ryan
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [7025]) Workaround Safari crasher. Props azaozz. fixes #5945

#7 @douglsmith
14 years ago

I have confirmed that the fix does work here.

Note: See TracTickets for help on using tickets.