Make WordPress Core

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#59469 closed defect (bug) (duplicate)

Navigation menu styles are missing

Reported by: kafleg's profile kafleg Owned by:
Milestone: Priority: normal
Severity: major Version: 6.4
Component: Editor Keywords:
Focuses: Cc:

Description

The site front view is not loaded properly, it is broken. https://i.rankmath.com/i/QRElqE

  • WordPress 6.4 Beta 1
  • PHP 8.1
  • Laragon Local server

Attachments (1)

themett4.jpg (244.8 KB) - added by kafleg 5 months ago.

Download all attachments as: .zip

Change History (20)

#1 @mukesh27
5 months ago

@kafleg I can't reproduce the same issue on production sites. Could you please share more details?

#2 @kafleg
5 months ago

Oh, I missed to say,

  • Updated WordPress 6.3.2 to 6.4 Beta 1 via WP-CLI

#3 @hellofromTonya
5 months ago

  • Keywords reporter-feedback needs-testing-info added; needs-testing removed
  • Milestone changed from Awaiting Review to 6.4

Hello @kafleg

Welcome back to Core's Trac :)

I'm also not able to reproduce the broken layouts, though they are clearly broken as shown in your screenshot.

Looking at your screenshot, I see the Warning that was tracked in #59468 and resolved by [56731]. I'm wondering if that bug contributed to the issue you're seeing. Could you retest to verify?

If it still broken, can you also share if there are any plugins activated and if indeed it's the new default TT4 (Twenty Twenty-Four) theme that's activated. Thank you :)

Moving this ticket into 6.4.

#4 @kafleg
5 months ago

Hi @hellofromTonya and @mukesh27

I checked it again in private window with fresh setup.

See the screenshot.

Thank you
KafleG

@kafleg
5 months ago

#5 @kafleg
5 months ago

I just updated another WordPress 6.3 to 6.4 Beta 1 with WP CLI, i see a similar issue.
https://i.rankmath.com/i/blgMaI

And this is not a theme issue. I activated other theme as well and I found the similar issue.

But there is no issue once the Gutenberg, Version 16.7.0 plugin is activated.

#6 @shailu25
5 months ago

I am able to Reproduce this issue.

But After Activating Gutenberg Plugin then issue are resolved. (So there is no issue with themes)

Step to Reproduce:

  • New install of 6.4 Beta 1
  • Themes: TT3, TT4 , TT2
  • Plugins: none
  • OS : Windows
  • PHP Version: 8.0.18
  • Localhost : Xampp

Screenshot:

Screenshot with Gutenberg Plugin:

Version 3, edited 5 months ago by shailu25 (previous) (next) (diff)

#7 @harshgajipara
5 months ago

Test Report

As per feedback in last report, I am able to reproduce the issue. and also after activation of Gutenberg Plugin, issue gets resolved.

Environment:

OS: Windows
PHP: 8.1.9
WordPress: 6.4
Browser: Chrome
Theme: Twenty Twenty Four

Actual Results:

✅ Before activating gutenberg, issue persist: https://prnt.sc/-WdGeIzJTdzG
✅ After activating gutenberg, issue resolved: https://prnt.sc/BxurPQNsB_OF

Last edited 5 months ago by harshgajipara (previous) (diff)

#8 @darshitrajyaguru97
5 months ago

as per the last feedback report, I am able to reproduce same issue. And the issue gets resolved by the activate Gutenberg plugin.

Environment:
===========

OS: Windows
PHP: 8.2.4
WordPress: 6.4
Browser: Chrome
Theme: Twenty Twenty Four

Screenshots:
===========

Before Activate Gutenberg Plugin: https://prnt.sc/fx5cn9L1l_fB
After Activate Gutenberg Plugin: https://prnt.sc/43eAcPnkIFEK

#9 @darshitrajyaguru97
5 months ago

as per the last feedback report, I am able to reproduce same issue. And the issue gets resolved by the activate Gutenberg plugin.

Environment:
===========

OS: Windows
PHP: 8.2.4
WordPress: 6.4
Browser: Chrome
Theme: Twenty Twenty Four

Screenshots:
===========

Before Activate Gutenberg Plugin: https://prnt.sc/fx5cn9L1l_fB
After Activate Gutenberg Plugin: https://prnt.sc/43eAcPnkIFEK

This ticket was mentioned in Slack in #core by shailu25. View the logs.


5 months ago

#11 @SergeyBiryukov
5 months ago

  • Component changed from General to Editor

#12 @SergeyBiryukov
5 months ago

#59470 was marked as a duplicate.

#13 @SergeyBiryukov
5 months ago

  • Summary changed from Broken site to Navigation menu styles are missing

#14 @ashikur698
5 months ago

I tried to recreate the same issue in the 6.4 Beta 2 version. Can't produce the same issue.

Environment:
===========
OS: MAC Ventura 13.1
PHP: 8.1.23
WordPress: 6.4
Browser: Chrome
Theme: Twenty Twenty Two & Three

Screenshots:
===========
TT2 - https://prnt.sc/OoA9Dd_tr0t4
TT3 - https://prnt.sc/fZcg8m6w4_rD

#15 @pbiron
5 months ago

it's more than just the navigation CSS that's missing. From what I can tell, all core block CSS is failing to load in 6.4-beta1 and beta2 when any block-based theme is active (when a classic theme is active the block CSS is loading fine).

I can also confirm that when GB (6.6.0 or higher) is active the problem goes away.

Environment

OS: Windows
PHP: 8.0.29
WordPress: 6.4-beta1 and beta2
Browser: Chrome
Theme: TT4, TT3, TT2, custom block theme, T17, custom classic theme

#16 @hellofromTonya
5 months ago

  • Keywords reporter-feedback needs-testing-info removed

Pinging the 6.4 Editor Tech and Triage Leads for awareness @mikachan @siobhyb @karmatosed @annezazu @bph.

This ticket was mentioned in Slack in #core by hellofromtonya. View the logs.


5 months ago

#18 @joemcgill
5 months ago

  • Milestone 6.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This looks to be a duplicate of the issue reported in #59489. Can folks experiencing this issue see if that patch fixes the issue? If not, then we can reopen this one.

#19 @kafleg
5 months ago

@joemcgill But I think this ticket was created earlier than #59489. I don't think this is a duplicate of that.

Note: See TracTickets for help on using tickets.