Make WordPress Core

Opened 9 months ago

Closed 6 weeks ago

#59497 closed defect (bug) (invalid)

There are pages or posts are not working update

Reported by: utsav72640's profile utsav72640 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4
Component: General Keywords: needs-testing has-testing-info reporter-feedback close
Focuses: Cc:

Description

I recently performed a fresh installation of WordPress 6.4. However, I have encountered an issue where I am unable to update posts or pages. I have attached a video URL to illustrate the problem. Please review the video, and if you have any questions or can identify the issue, kindly let me know.

Video URL : https://www.awesomescreenshot.com/video/21181741?key=0bcb4cbfebeac453b9dcd5d8c428290a

### Environment
WordPress: 6.4-beta1
PHP: 8.0.28
Server: Apache/2.4.56 (Unix) OpenSSL/1.1.1t PHP/8.0.28 mod_perl/2.0.12 Perl/v5.34.1
Database: mysqli (Server: 10.4.28-MariaDB / Client: 8.0.28)
Browser: Chrome 117.0.0.0 (macOS)
Theme: Twenty Twenty-Four 1.0
MU-Plugins: None activated
Plugins: WordPress Beta Tester 3.5.4

Change History (9)

#1 @jrf
9 months ago

  • Focuses php-compatibility removed

Please post the error messages you are seeing (in detail) in the ticket to make it easier for people to understand the problem and to verify if they can reproduce it.

Note: based on the video, this is not a PHP Compatibility issue.

#2 @sumitsingh
8 months ago

  • Keywords has-testing-info added

Hey,

I have checked and working fine with PHP 8.0*. Saw your video also. The REST API may be disabled/not working on your local system, as all API links are showing up as 404 on your recordings. I have tested locally and on live server. Working fine with PHP 8.* version and 6.4 beta version.

you can see here my quick video - https://www.awesomescreenshot.com/video/21270918?key=af791a31b2df02fba1ae200a53cb66fb

Can you share your site health Info & active theme name, please?

Version 3, edited 8 months ago by sumitsingh (previous) (next) (diff)

This ticket was mentioned in Slack in #community-team by sumitsingh. View the logs.


8 months ago

#4 @hellofromTonya
8 months ago

  • Keywords reporter-feedback added

Hello @utsav72640,

Welcome to WordPress Core's Trac :) Thank you for reporting the issue you experienced with 6.4 Beta 1.

I'm not able to reproduce the issue with 6.4 RC2. Are you able to retest using RC2? Instructions are here.

This ticket was mentioned in Slack in #core by jorbin. View the logs.


6 months ago

#6 @lakshmananphp
6 months ago

Note:

This is an env-related issue rather than a core bug. This error occurs when the htaccess file is not found and makes the wp-json/ path not work, eventually resulting in the error as reported in the ticket.

Bug Test report

Bug scrub update

Props to @khoipro @jorbin

The error occurs when .htaccess files is not found.
Saving permalinks would help create or update the htaccess and hence solves this issue.

Environment

  • WordPress: 6.4.2
  • PHP: 8.1.20
  • Server: Apache/2.4.57 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.1.1f
  • Database: mysqli (Server: 10.6.14-MariaDB-1:10.6.14+maria~ubu2004 / Client: mysqlnd 8.1.20)
  • Browser: Chrome 120.0.0.0 (macOS)
  • Theme: Twenty Twenty-Four 1.0
  • MU-Plugins: None activated
  • Plugins:
    • WordPress Beta Tester 3.5.5

Steps to Reproduce

  1. Rename .htaccess
  2. Add a new post or page
  3. 🐞 Bug occurs.

Expected Results

  1. ✅ save without errors

Actual Results

  1. ❌ Unable to save

Steps to fix

Save permalinks again (to generate htaccess or update it)
Save works without errors

#7 @jorbin
6 months ago

  • Keywords close added

From watching the video, I think there is a chance that pretty permalinks were improperly setup or potentially damaged, but based on the info that isn't actionable. Please provide steps to reproduce, otherwise I think this should be closed as invalid.

#8 @jorbin
6 months ago

  • Milestone changed from Awaiting Review to Future Release

Also, moving to Future Release until there is more information.

#9 @hellofromTonya
6 weeks ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

From the video and test report, I agree with @jorbin comment:8:

From watching the video, I think there is a chance that pretty permalinks were improperly setup or potentially damaged, but based on the info that isn't actionable. Please provide steps to reproduce, otherwise I think this should be closed as invalid.

Closing the ticket with the assumption the issue is resolved and not related to Core (as it's been 5 months with no reporter follow-up).

@utsav72640 does this issue still happen today?
If no, yippee!
If yes, please reopen this ticket and provide step-by-step instructions on how to reproduce it. These type of information helps contributors investigate. Thank you.

Note: See TracTickets for help on using tickets.