WordPress.org

Make WordPress Core

Opened 17 years ago

Closed 17 years ago

#595 closed defect (bug) (fixed)

Calendar links broken with permalink without %day%

Reported by: trombonekenny Owned by: ryan
Milestone: Priority: normal
Severity: minor Version: 1.2.2
Component: Template Keywords:
Focuses: Cc:

Description

My permalink structure is /%year%/%monthnum%/%postname%/ which breaks links in the calendar. The output for the links in the calendar comes out as http://www-dave.cs.uiuc.edu/wordpress/%yea instead of http://www-dave.cs.uiuc.edu/wordpress/2004/12/merry-merry/

Looking at the source, it looks like the problem is in get_day_link and some special manipulation it does for %day% If I put %day% in my permalink structure, the calendar works fine.

Change History (2)

#1 @trombonekenny
17 years ago

  • Patch set to No

#2 @ryan
17 years ago

  • fixed_in_version set to 1.5
  • Owner changed from anonymous to rboren
  • Resolution changed from 10 to 20
  • Status changed from new to closed

Known bug. Fixed in 1.5.

Note: See TracTickets for help on using tickets.