Make WordPress Core

Opened 9 months ago

Closed 9 months ago

#59512 closed feature request (duplicate)

Add filtering system to Media Library

Reported by: ababir's profile ababir Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

The current Media Library on the WordPress dashboard does not have a filtering system, making it difficult to find specific media items, especially in large libraries. This is a major pain point for many users, as it can be very time-consuming to scroll through hundreds or even thousands of media items to find the one they need.

I propose adding a filtering system to the Media Library that would allow users to filter media items by:

Color tags: Users could add color tags to their media items, and then filter by tag to quickly find all media items with a specific tag. This would be especially useful for grouping images by color, such as product images or event photos.

Custom tags: Users could also create their own custom tags and apply them to their media items. This would allow users to filter media items in any way they need, such as by project, client, or event.

The filtering system should be easy to use and intuitive. Users should be able to filter media items from the Media Library list view or from the media item details view.

Change History (2)

#1 @sabernhardt
9 months ago

  • Component changed from General to Media

#2 @swissspidy
9 months ago

  • Keywords needs-design needs-design-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there and thanks for opening the ticket.

This has come up multiple times in the past, which is why I am closing this as a duplicate of #23594 which has more discussion on it.

Right now plugins can enabled this sort of filtering by adding custom taxonomies. I also expect the ticket to be reopened because phase 3 of Gutenberg will look very closely at improving media in WordPress and overhauling the media library as well. So improved categorization is definitely among that!

Note: See TracTickets for help on using tickets.