WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#5952 closed defect (bug) (duplicate)

Norwegian/Danish national characters mess up post slugs

Reported by: dnusim Owned by:
Milestone: Priority: normal
Severity: major Version: 2.3.3
Component: I18N Keywords: needs-patch
Focuses: Cc:

Description

When the post slug is generated from the post title, the letter 'Å' 'å' converts to 'a', should convert to 'aa' which is the general practice in countries using this character (Confer Wikipedia).

Furthermore, the Norwegian/Danish characters 'Æ' 'æ' and 'Ø' 'ø' should be converted to respectively 'ae' and 'oe'. As of now, these convert to '%c3%a6' and '%c3%b8'.

Some may consider this a dupe of #4739.

Change History (2)

#1 @westi
10 years ago

  • Milestone 2.6 deleted

This is definitely a dupe of #4739.

Closing as such

#2 @hansengel
10 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Westi, you forgot to close it :P

Note: See TracTickets for help on using tickets.