Make WordPress Core

Opened 9 months ago

Closed 9 months ago

#59554 closed defect (bug) (duplicate)

PHP 8.1: Community-Events on Dashboard producing deprecated warnings

Reported by: treibstoff's profile treibstoff Owned by:
Milestone: Priority: normal
Severity: minor Version: 6.3.1
Component: General Keywords: php81 needs-patch
Focuses: Cc:

Description

With PHP 8.1 and WP 6.3.1
If the commmunity-events on dashbord is on, it will produce lots of warnings:

Deprecated: html_entity_decode(): Passing null to parameter #1 ($string) of type string is deprecated in wp-includes/widgets.php on line 1626

if I delete the View of Community-Events from the Dashboard & delete the related transient the message is gone.

The related Transient:
_site_transient_community-events-3383c416d96e7e74e08084a6fca31eaf

It caused also an unserelize PHP Error in query monitor.

belonging to this is also Transient:
_transient_feed_f014c832422b67a4cec692b17aa40756

This happens meanwhile on 4 totally different wordpress installations and hoster.

Change History (1)

#1 @jrf
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from major to minor
  • Status changed from new to closed

Duplicate of #59052.

Note: See TracTickets for help on using tickets.