Make WordPress Core

Opened 5 months ago

Last modified 5 months ago

#59556 new defect (bug)

WordPress Multisite issue - Media files presenting on Google with wrong domain

Reported by: nutsonshells's profile nutsonshells Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 6.3.1
Component: Networks and Sites Keywords: has-screenshots
Focuses: multisite Cc:

Description (last modified by costdev)

Hi WordPress Team,

I have a WordPress Multisite set up with 6 sites. Each site has its own domain name.

I discovered on a google search, that an uploaded media file is incorrectly referenced and basically "shared" between domains.

I have google showing a link to a file on site #17, but it is referencing the domain name for site #20.

Google shows:

https://site20domain/wp-content/uploads/sites/17/filename.pdf

But it should be showing:

https://site17domain/wp-content/uploads/sites/17/filename.pdf

See also attached screenshots.

Thanks

Kind regards,

Regine

Attachments (2)

domain with site number info.png (33.9 KB) - added by nutsonshells 5 months ago.
Search result.png (111.3 KB) - added by nutsonshells 5 months ago.

Download all attachments as: .zip

Change History (3)

#1 @costdev
5 months ago

  • Description modified (diff)
  • Keywords has-screenshots added

Hi @nutsonshells, welcome to Trac and thanks for opening this ticket!

I'm just commenting to make a few adjustments to the ticket's description and note that it has-screenshots.

If you think of any more information that may be useful for those who will look into this, please feel free to post additional comments. 🙂

Note: See TracTickets for help on using tickets.