Make WordPress Core

Opened 6 months ago

Closed 6 months ago

#59589 closed defect (bug) (duplicate)

PHP error in class-wp-plugins-list-table.php after r56599

Reported by: petitphp's profile petitphp Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4
Component: Administration Keywords:
Focuses: administration Cc:

Description

Originally reported in #57791 by TobiasBg

With an incompatible PHP version (just set a plugin's "Requires PHP" header to e.g. 8.4), I'm now getting

Uncaught ArgumentCountError: 2 arguments are required, 1 given in /var/www/html/wordpress/wp-admin/includes/class-wp-plugins-list-table.php:1282

This is caused by the removal of the comma at the end of line 1285 in wp-admin/includes/class-wp-plugins-list-table.php, which was done in https://core.trac.wordpress.org/changeset/56599#file4, when only the HTML code should have been removed. printf() has only one argument then.

Change History (1)

#1 @TobiasBg
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #59590.

Note: See TracTickets for help on using tickets.