Make WordPress Core

Opened 10 months ago

Closed 9 months ago

#59598 closed defect (bug) (fixed)

Applying Lightbox "Click on Expand" on 1 Image Block Automatically Adds the Option on All Other Images

Reported by: sunitarai's profile sunitarai Owned by:
Milestone: 6.4 Priority: normal
Severity: normal Version:
Component: General Keywords: gutenberg-merge
Focuses: Cc:

Description

I installed WordPress 6.4 Beta 3 via the Beta Tester plugin and the 2024 theme has been activated.

I went to Appearance> Editor > Templates > Blog Home and then added the "Click on Expand" option on the first image on the template.

And, when I checked the preview after saving the changes, I could see the Lightbox option had been automatically added to all the other images on the template.

Attachments (1)

WP-6.4.Beta3-Ticket-59598.mp4 (6.1 MB) - added by sunitarai 10 months ago.
Applying Lightbox "Click on Expand" on 1 Image Block Automatically Adds the Option on All Other Images

Change History (11)

@sunitarai
10 months ago

Applying Lightbox "Click on Expand" on 1 Image Block Automatically Adds the Option on All Other Images

#1 @kafleg
10 months ago

Welcome @sunitarai

I'm also able to reproduce the same issue.

#2 @digamberpradhan
10 months ago

Have checked and can confirm the issue too. https://screenpal.com/watch/c06XDOV57HP

#3 @hellofromTonya
10 months ago

  • Milestone changed from Awaiting Review to 6.4

Hello @sunitarai,

Welcome to WordPress Core's Trac :) Thank you for reporting this issue.

The "Click on Expand" option and Lightbox feature is being maintained in the Gutenberg repo. Thus this issue needs to be reported upstream in Gutenberg.

Why report upstream?
WordPress Core consumes / uses the packages that Gutenberg maintains and publishes. Core itself cannot directly modify the code in those packages to address the issue you are reporting.

@sunitarai or @kafleg are you available to report this bug upstream in Gutenberg?

If yes (Thank You) and if possible, please:

  • add the following labels: [Block] Image and [Type] Bug.
  • and copy / paste a link to the reported issue back here in this Trac ticket for monitoring / tracking.

Until reported upstream, pulling this ticket into the 6.4 milestone for awareness and tracking.

#4 @kafleg
10 months ago

Hello @hellofromTonya

Thank you for checking. Okay, we can create that in the Gutenberg repo as well.

This ticket was created while we were running a knowledge-sharing webinar and we found this is the best place to get started for submitting the bug.

@sunitarai Can you create in the Gutenberg repo? https://github.com/WordPress/gutenberg/issues/new?assignees=&labels=&projects=&template=Bug_report.yml

#5 @sunitarai
10 months ago

Thank you so much @kafleg and @digamberpradhan for testing the issue.

@hellofromTonya, thank you so much for the direction. I have created the ticket on the Gutenberg repo also. Here's the link: https://github.com/WordPress/gutenberg/issues/55290

This ticket was mentioned in Slack in #core by oglekler. View the logs.


10 months ago

#7 @oglekler
10 months ago

  • Keywords gutenberg-merge added

This looks like it should be addressed on the Gutenberg side, so, I am marking this as gutenberg-merge.

#8 @poena
10 months ago

Hi
This is a duplicate of https://github.com/WordPress/gutenberg/pull/5519.
The problem has been solved and the fix is already planned to be included in 6.4 RC1:
https://github.com/WordPress/gutenberg/pull/55120#issuecomment-1757410223

#9 @digamberpradhan
10 months ago

@poena I think the referred pull request is incorrect. Do you mean https://github.com/WordPress/gutenberg/issues/55119 ?

Last edited 10 months ago by digamberpradhan (previous) (diff)

#10 @hellofromTonya
9 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Thank you everyone.

Some history:

Closing this ticket as fixed by [56849].

If the problem persists, please re-open this Trac ticket and this Gutenberg issue. Thank you :)

Note: See TracTickets for help on using tickets.