Make WordPress Core

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#59714 closed defect (bug) (duplicate)

Not possible to set excerpt_length when doing ajax

Reported by: pelentak's profile pelentak Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.3
Component: General Keywords: has-patch
Focuses: Cc:

Description

A filter added to make post excerpt length to 100 in the context of block editor (see here: https://github.com/WordPress/wordpress-develop/commit/a710b97e7c7463d663664f7266ce6d72eb95238c#diff-662eebf6d91c9208094ca7df3c7a1e26d3dd96162004d3291a84a5a0aef705c9R86-R95) makes it impossible for excerpt_length to be overridden when doing ajax.

Change History (2)

#1 @swissspidy
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from trunk to 6.3

Duplicate of #59043.

This ticket was mentioned in PR #5563 on WordPress/wordpress-develop by @dornaweb.


9 months ago
#2

  • Keywords has-patch added

A filter added to make post excerpt length to 100 in the context of block editor (see here) makes it impossible for excerpt_length to be overridden when doing ajax.
This PR opts out when doing ajax, allowing themes, plugins override the excerpt_length when doing ajax (for example fetching a post template via ajax)

Trac ticket: https://core.trac.wordpress.org/ticket/59714

Note: See TracTickets for help on using tickets.