Make WordPress Core

Opened 9 months ago

Closed 7 months ago

Last modified 6 months ago

#59730 closed enhancement (duplicate)

Bump the minimum required Node version to v20

Reported by: noahtallen's profile noahtallen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: has-patch
Focuses: Cc:

Description

Now that Node 20 is the current active LTS, with both 18 and 16 being deprecated, it's worth exploring an update! This would first require Node 20 to be available on the build server.

Change History (6)

This ticket was mentioned in PR #5571 on WordPress/wordpress-develop by noahtallen.


9 months ago
#1

  • Keywords has-patch added

Similar to #4028, updates the repository to NodeJS 20 and npm 10, which is now the current active LTS. Would supersede #5515 once v20 is on the build server!

#2 @swissspidy
9 months ago

Shouldn't we re-use #59663 for this? 🤔

#3 @noahtallen
9 months ago

That works for me! If we don't have 18 available on the build server more quickly, I suppose we might still want to update to 18 first and then 20 later.

Last edited 9 months ago by noahtallen (previous) (diff)

noahtallen commented on PR #5571:


9 months ago
#4

Some of the Gutenberg failures above are because it's not yet on version 20 either.

#5 @desrosj
7 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #59663.

noahtallen commented on PR #5571:


6 months ago
#6

Done elsewhere :)

Note: See TracTickets for help on using tickets.