Make WordPress Core

Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#5979 closed defect (bug) (invalid)

wordpress infinite redirect bug

Reported by: trenta Owned by: markjaquith
Milestone: Priority: normal
Severity: normal Version:
Component: Canonical Keywords: reporter-feedback
Focuses: Cc:


I am proxying wordpress as follows, to a machine called "wordpress".

ProxyPass / http://wordpress/
ProxyPassReverse / http://wordpress/

I can fix the infinite redirect by changing the name of the destination server. But, that would be a hack. What I really would like, is for wordpress to act in a reasonable way, by not requiring that the requested host name is the same as my domain name configured in the options. If this is not fixed, no body will be able to proxy, for instance http://mydomainname.com/wordpress to http://blog.otherdomainname.com

Other possibilities are if hosting providers do proxying without it being configurable. This would prevent the user from fixing the problem.

Most people would not be able to figure this out. As such, it should be a fairly high priority.

Change History (5)

#1 @ionfish
8 years ago

This looks like a duplicate of #5089.

#2 @Denis-de-Bernardy
7 years ago

  • Component changed from General to Canonical
  • Owner changed from anonymous to markjaquith

#3 @westi
6 years ago

  • Keywords reporter-feedback added
  • Milestone changed from 2.9 to Future Release

We need more info here to investigate and reproduce.

What urls are you configuring the WordPress install to have?

Moving to Future until we have enough info to investigate.

#4 @markjaquith
6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This is no longer valid. We only forward yes-www vs no-www domains now. incorrect.example.com will not forward to correct.example.com — you'll only get redirects from www.correct.example.com

#5 @Denis-de-Bernardy
6 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.