Make WordPress Core

Opened 9 months ago

Closed 3 months ago

Last modified 6 weeks ago

#59800 closed defect (bug) (duplicate)

Twenty Fourteen: Pullquote block does not support custom font size

Reported by: nidhidhandhukiya's profile nidhidhandhukiya Owned by: karmatosed's profile karmatosed
Milestone: Priority: normal
Severity: normal Version: 5.9
Component: Bundled Theme Keywords:
Focuses: css Cc:

Description

Steps to reproduce the issue :-

  1. Activate Twenty Fourteen theme.
  2. Choose Pullquote block.
  3. Change font size from the settings.

You can able to see both the side there is no change in font size.
I have attached video for better understanding.
Video URL :- https://share.cleanshot.com/rsTnRLQstYrhDc6lXT1z

Attachments (3)

59800.patch (853 bytes) - added by nidhidhandhukiya 9 months ago.
59800.diff (3.4 KB) - added by shailu25 3 months ago.
Patch Added
59800.1.diff (1.9 KB) - added by sabernhardt 3 months ago.
restores default 19px for blockquote elements and inherits custom font sizes in Pullquote blocks

Download all attachments as: .zip

Change History (18)

#1 @huzaifaalmesbah
9 months ago

  • Keywords has-patch has-testing-info added

#2 @karmatosed
3 months ago

  • Keywords commit added; has-patch has-testing-info removed

@nidhidhandhukiya thank you for the patch. I can see this does solve it. There is a consideration perhaps of how to refine the jumping that happens around of the visual as it goes up and down in size. My concern though in doing that would be making a design decision - so for now let's avoid that and commit this. Thank you for working on this.

#3 @karmatosed
3 months ago

  • Milestone changed from Awaiting Review to Future Release

#4 @karmatosed
3 months ago

  • Milestone changed from Future Release to 6.5.3

#5 @karmatosed
3 months ago

  • Owner set to karmatosed
  • Resolution set to fixed
  • Status changed from new to closed

In 57989:

Twenty Fourteen: Fixes pullquote block issues with font sizing.

The pullquote block was not showing increase in sizes within the editor. This solves that and allows you to see the change both in the editor and front.

Props nidhidhandhukiya, huzaifaalmesbah.
Fixes #59800.

#6 @sabernhardt
3 months ago

  • Focuses css added
  • Keywords needs-patch added; commit removed
  • Milestone changed from 6.5.3 to 6.6
  • Summary changed from Twenty Fourteen : Pullquote block having issue with font size. to Twenty Fourteen: Pullquote block does not support custom font size

[57989] changes the default font size of Pullquote blocks, Quote blocks, and blockquote elements in the Classic block/Classic Editor from 19px.

  • Pullquote blocks increased to 24px
  • Quote blocks and Classic quotes decreased to 16px

This is also not urgent enough to create a new version of the theme before July.

#7 @sabernhardt
3 months ago

I made a set of blocks to show the default font size plus the Large preset and a custom font size.

#8 @sabernhardt
3 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

@shailu25
3 months ago

Patch Added

#9 @shailu25
3 months ago

  • Keywords has-patch added; needs-patch removed

Updated Changes as per mentioned above.

  • Added Default Font size Same as before(font-size:19px) for Blockquote & Pullquote & Quote blocks
  • Inherited font size when custom font size is selected in editor so it will show selected font size in backend & frontend.

@sabernhardt
3 months ago

restores default 19px for blockquote elements and inherits custom font sizes in Pullquote blocks

#10 @sabernhardt
3 months ago

  • Version changed from 6.3.2 to 5.9

Thanks for creating the patch! I did not find a need to inherit a font size for the Quote block or the p and cite elements with Twenty Fourteen, though.

59800.1.diff

  • restores the default 19px for any blockquote element
  • uses low specificity for front end
  • uses more specific selectors to override .editor-styles-wrapper blockquote in non-framed editor
  • does not change sizes for the Quote block

#11 @mayur8991
3 months ago

Patch Report - https://core.trac.wordpress.org/attachment/ticket/59800/59800.1.diff

Environment

WordPress - 6.5
OS - Windows
Browser - Firefox
Theme: Twenty Fourteen
PHP - 8.1.23

Before

After Patch

Result : Pullquote block custom font size working fine

#12 @karmatosed
3 months ago

  • Keywords close added; has-patch removed

Closing this one to focus on: https://core.trac.wordpress.org/ticket/61034

#13 @karmatosed
3 months ago

  • Milestone 6.6 deleted
  • Resolution set to invalid
  • Status changed from reopened to closed

#14 @karmatosed
3 months ago

  • Resolution changed from invalid to fixed

#15 @sabernhardt
6 weeks ago

  • Keywords close removed
  • Resolution changed from fixed to duplicate

Duplicate of #61034.

Note: See TracTickets for help on using tickets.