Make WordPress Core

Opened 8 months ago

Closed 3 months ago

#59807 closed defect (bug) (wontfix)

Comments not shown for the "page" post type when using TT4

Reported by: rajinsharwar's profile rajinsharwar Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4
Component: Bundled Theme Keywords: close 2nd-opinion
Focuses: Cc:

Description

I am not sure if this is an intended thing, but when we switch to TT4, and enable the Discussion > "Allow Comments", there is no option to comment on that page.

But, immediately after switching to the TT3 theme, we can see the option to comment on the pages. Not sure, if this is done intentionally, if it is, why is there the setting of "Allow Comments" on the "page" post type?

NOTE: Comments are showing up on the Posts, the problem is happening on the "page" post type.

https://prnt.sc/s2NirqU51_21

Change History (4)

#1 @poena
8 months ago

Hi @rajinsharwar
This is intentional. If you want to enable comments, you need to do two things:

1) Make sure comments are enabled site wide or on the specific page,
2) Add the comments block to the template that the page is using. Or if you only want a comments area on the current page, but not all pages, then add that block to the page content in the block editor.

#2 @poena
5 months ago

  • Keywords close 2nd-opinion added
  • Version set to 6.4

@jordesign Hi Jordan, do you perhaps have insight in if this comments area is frequently requested in the support form?
@beafialho Hi Bea, is there anything else you would like to add about the choice to not include a comments section on pages?

If not, I propose closing this as wontfix.

#3 @jordesign
5 months ago

@poena To be perfectly honest - I don't think I've come across a single one in the Forums.

#4 @karmatosed
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thank you @jordesign for that confirmation. Based on this I am going to follow through with the closing of this ticket based on the recommendation of @poena. Thank you everyone for collaborating on this.

Note: See TracTickets for help on using tickets.