Make WordPress Core

Opened 9 months ago

Closed 3 months ago

#59808 closed defect (bug) (invalid)

Custom fontSizes show up duplicated on the Editor along with default presets.

Reported by: autranalexandre's profile autranalexandre Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.3.2
Component: Editor Keywords: reporter-feedback close
Focuses: Cc:

Description

When setting up custom fontSizes on theme.json, they show up duplicated on the Editor. However, if you select one of the default values, the input still selects the custom values.

theme.json

"settings": {
  "typography": {
    "fontSizes": [
        {
          "slug": "small",
          "size": "0.5rem",
          "name": "Small"
        },
        {
          "slug": "medium",
          "size": "1rem",
          "name": "Medium"
        },
        {
          "slug": "large",
          "size": "2rem",
          "name": "Large"
        },
        {
          "slug": "x-large",
          "size": "3rem",
          "name": "Extra Large"
        }
      ]
  }
}

Screenshot:
https://autran.pro/test/wordpress.png

Expected Behavior: overriden default properties should not show up on the Editor.

Actual Behavior: default properties are shown together with custom settings.

Note: I've only yesterday started to learn/use WordPress - I am not sure how to properly flag bugs - if there's documentation on standards, please point me to it, I'd be happy to adjust. I also could not find this issue for 6.3.2 on previous tickets - apologies if it's duplicated.

Change History (2)

#1 @hellofromTonya
9 months ago

  • Component changed from General to Editor
  • Keywords reporter-feedback close added

Hello @autranalexandre,

Welcome to WordPress Core Trac :) Thank you for reporting this issue.

There's currently a possibly related issue opened in Gutenberg:
Font Size Picker displays incorrect font-sizes in incorrect order.

Is the issue you're reporting related to it?

  • If yes, can you please add your findings to that issue?

Once reported upstream, then this ticket can be closed as reported-upstream.

Why close here?
To shift the discussion, investigation, and resolution upstream where the work will happen.

Why report upstream?
Issues with the editor and/or its tools are investigated and resolved upstream in the Gutenberg repository. Why? The editor and its tools are within the frontend npm packages which are maintained by and released in Gutenberg.

How do the changes get into Core?
Core consumes these npm packages through version updates in its package.json file.

I'll mark this Trac ticket as a close candidate to alert that it will be closed once reported upstream.

Thank you :)

#2 @hellofromTonya
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hello again @autranalexandre,

Does this issue still happen today for you? If yes and you haven't yet done so, please open a bug report in the Gutenberg repository? As I noted in comment:1, the discussion and resolution would happen in Gutenberg.

As there's been no reporter follow-up since opened, closing this ticket as invalid (which means it's likely not a Core issue). If the issue still persists and gets reported and resolved in Gutenberg, then the resolution of this ticket should change from invalid to reported-upstream with a link to the Gutenberg issue.

Note: See TracTickets for help on using tickets.