Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#59812 closed defect (bug) (fixed)

Twenty Twenty-Four: fixed contrast issues, improved documentations, general polishing before release

Reported by: onemaggie's profile onemaggie Owned by: hellofromtonya's profile hellofromTonya
Milestone: 6.4 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch commit dev-reviewed
Focuses: Cc:

Description (last modified by sabernhardt)

This PR includes the last fixes to the theme before the release:

Addresses some issues with contrast on some of the theme variations, we ended up removing a color that is no longer used from the theme and variations.
Fixes an issue with a pattern that was using the wrong unit type for the min-height.
Moves wp_enqueue_block_style call to its own function for clarity.
Updates the link to the docs on the changelog

Props:

onemaggie, richtabor, luminuu, huzaifaalmesbah, sabernhardt, poena

Change History (14)

This ticket was mentioned in PR #5623 on WordPress/wordpress-develop by @onemaggie.


5 months ago
#1

  • Keywords has-patch added

Trac ticket: https://core.trac.wordpress.org/ticket/59812

This PR includes the last fixes to the theme before the release:

https://github.com/WordPress/twentytwentyfour/pull/723
https://github.com/WordPress/twentytwentyfour/pull/718
https://github.com/WordPress/twentytwentyfour/pull/719
https://github.com/WordPress/twentytwentyfour/pull/720
https://github.com/WordPress/twentytwentyfour/pull/722

Addresses some issues with contrast on some of the theme variations, we ended up removing a color that is no longer used from the theme and variations.
Fixes an issue with a pattern that was using the wrong unit type for the min-height.
Moves wp_enqueue_block_style call to its own function for clarity.
Updates the link to the docs on the changelog

Props:

onemaggie, richtabor, luminuu, huzaifaalmesbah, sabernhardt, poena

#2 @sabernhardt
5 months ago

  • Description modified (diff)
  • Summary changed from Twenty twenty-four: fixed contrast issues, improved documentations, general polishing before release to Twenty Twenty-Four: fixed contrast issues, improved documentations, general polishing before release

#3 @sabernhardt
5 months ago

  • Milestone changed from Awaiting Review to 6.4

#4 @rajinsharwar
5 months ago

Tested out the patch.

  1. It resolves the issue with min-height with the pattern shown in PR 720. 🟢
  2. Solves the colour issue mentioned in PR 722 🟢

#5 @hellofromTonya
5 months ago

  • Owner set to hellofromTonya
  • Status changed from new to reviewing

Reviewing for commit.

@hellofromTonya commented on PR #5623:


5 months ago
#6

Confirmed changes are ported to this PR ✅

Next step: Test the PR to ensure the theme loads and renders without errors.

#7 @hellofromTonya
5 months ago

  • Keywords commit added

Patch:

The patch is approved and ready for commit:

  • Includes the recent changes since RC3 ✅
  • Renders properly without errors ✅
  • Has a test report to confirm the changes work - see comment:4

Preparing the commit to trunk now.

#8 @hellofromTonya
5 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 57067:

Twenty Twenty-Four: Bugfixes and refinement for 6.4 RC4.

This update includes the following changes:

Follow up to [57036], [56999], [56951], [56813], [56764], [56716].

Props onemaggie, richtabor, luminuu, huzaifaalmesbah, sabernhardt, poena, rajinsharwar.
Fixes #59812.

#9 @hellofromTonya
5 months ago

  • Keywords dev-feedback added

Reopening for 2nd committer review / sign-off to backport [57067] to the 6.4 branch.

#10 @hellofromTonya
5 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#12 @desrosj
5 months ago

  • Keywords dev-reviewed added; dev-feedback removed

[57067] is good for backport!

#13 @hellofromTonya
5 months ago

Thank you @desrosj :) Backporting now.

#14 @hellofromTonya
5 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 57070:

Twenty Twenty-Four: Bugfixes and refinement for 6.4 RC4.

This update includes the following changes:

Follow up to [57036], [56999], [56951], [56813], [56764], [56716].

Reviewed by desrosj.
Merges [57067] to the 6.4 branch.

Props onemaggie, richtabor, luminuu, huzaifaalmesbah, sabernhardt, poena, rajinsharwar.
Fixes #59812.

Note: See TracTickets for help on using tickets.