Make WordPress Core

Opened 7 months ago

Closed 7 months ago

#59813 closed enhancement (duplicate)

Terms need a rich text editor

Reported by: joostdevalk's profile joostdevalk Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords:
Focuses: Cc:

Description

Both categories and tags (terms) can have "description" texts. Unfortunately, right now, the interface of WordPress does not allow making that description more than just a few strings, as terms currently only have a text input field.

Yoast SEO turns those input fields into rich text fields (and has done this for a long time already). See the attached screenshots for the difference.

I think we should make this the default behavior. People should be able to write term descriptions that have links and images, at the very least, as this would make these pages better for everyone.

Attachments (2)

tag-edit-without-yoast-seo.png (56.1 KB) - added by joostdevalk 7 months ago.
Default tag edit screen in WordPress
tag-edit-with-yoast-seo.png (138.4 KB) - added by joostdevalk 7 months ago.
Tag edit screen with Yoast SEO enabled

Download all attachments as: .zip

Change History (4)

@joostdevalk
7 months ago

Default tag edit screen in WordPress

@joostdevalk
7 months ago

Tag edit screen with Yoast SEO enabled

#1 @swissspidy
7 months ago

Duplicate of #59703?

#2 @joostdevalk
7 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #59703.

Well, yes :P

Note: See TracTickets for help on using tickets.